summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-05 17:52:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-05 18:00:10 +0100
commite89eac190f0a49ee4fa87734f0f7205a272051ff (patch)
treec01e03472f1097be990d286f6bda1f2f1e7d97ae /dev-python/python-redmine
parentdev-python/python-stdnum: Enable py3.12 (diff)
downloadgentoo-e89eac190f0a49ee4fa87734f0f7205a272051ff.tar.gz
gentoo-e89eac190f0a49ee4fa87734f0f7205a272051ff.tar.bz2
gentoo-e89eac190f0a49ee4fa87734f0f7205a272051ff.zip
dev-python/python-redmine: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-redmine')
-rw-r--r--dev-python/python-redmine/python-redmine-2.4.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/python-redmine/python-redmine-2.4.0.ebuild b/dev-python/python-redmine/python-redmine-2.4.0.ebuild
index da55d3bf3c50..1492e5810aa4 100644
--- a/dev-python/python-redmine/python-redmine-2.4.0.ebuild
+++ b/dev-python/python-redmine/python-redmine-2.4.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -25,6 +25,12 @@ RDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # https://github.com/maxtepkeev/python-redmine/pull/332
+ sed -i -e 's:assertEquals:assertEqual:' tests/*.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
epytest -o addopts=
}