summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-17 09:42:12 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-17 09:55:24 +0100
commit25f1c93401579c4a9025141efce8ca29e8b3cc7e (patch)
tree704477bed77c5423c89148b27afa3e76162d5295 /dev-python/python-socks
parentdev-python/jsonpickle: Bump to 1.5.0 (diff)
downloadgentoo-25f1c93401579c4a9025141efce8ca29e8b3cc7e.tar.gz
gentoo-25f1c93401579c4a9025141efce8ca29e8b3cc7e.tar.bz2
gentoo-25f1c93401579c4a9025141efce8ca29e8b3cc7e.zip
dev-python/python-socks: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-1.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 379ca0da8624..63fcc4b26f08 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,2 +1,3 @@
DIST python-socks-1.1.0.gh.tar.gz 1358296 BLAKE2B c599095a7f687ba1bba6f0ddbbc8ef2e680cb6be4e5d2250fad88c3a3273fb2044712045b20c5a358ed9dcbaef07e5133b6d672698d8caf4b978c9e633a5df70 SHA512 e38594815e5f943f810862dfe5d07a802601e41e879f68b4fa70c8087be0387a91e99e1b0578f2819557832b5e53be9773043a9617c72017c41e9377c4f35ef1
DIST python-socks-1.1.2.gh.tar.gz 29948 BLAKE2B c110cd8d5d055aa30a63cdade10e7e67b0d6f0b1b17e76ff40bfb85563c90e026f0169a7e943d1391d75e20d7dd715ab070a6adf9e1e247eccf906d63c324e66 SHA512 c62259e86e7afeba7ee3ef5cdca104846352137e5d5bfa6f475e2ac38b21fe1766aee6a1fcb6b9f725576613ce3d92663fab3682516b96caa3948a05d89333a7
+DIST python-socks-1.2.0.gh.tar.gz 31969 BLAKE2B f967d8100513455533132e7bb276a8f15a8486656c04493cb803640951d2cedaa0b9229386322846ff8992cfd13cf04470b017a615f33392880a4285c9ecd041 SHA512 c5db92b22ef1edef3a22b7ce79975e66f379da2bd8e9a629a15dc2995dfaef3d99d93eaf768ef593b6a7571ad580397290274e319707f36a883a9bcad20434b1
diff --git a/dev-python/python-socks/python-socks-1.2.0.ebuild b/dev-python/python-socks/python-socks-1.2.0.ebuild
new file mode 100644
index 000000000000..e4a5b571d8c0
--- /dev/null
+++ b/dev-python/python-socks/python-socks-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# tests rely on connecting to Internet
+RESTRICT="test"
+
+# trio, curio are not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+#BDEPEND="
+# test? (
+# dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+# dev-python/yarl[${PYTHON_USEDEP}]
+# )"
+
+#distutils_enable_tests pytest