summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-13 07:11:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-13 08:15:21 +0200
commitb265be9aff2622ae20a0d4c9839ab5a255f3ff41 (patch)
treebec918cc9d6339cf0a8444447112185190df2218 /dev-python/python-utils
parentapp-admin/awscli: Bump to 1.23.13 (diff)
downloadgentoo-b265be9aff2622ae20a0d4c9839ab5a255f3ff41.tar.gz
gentoo-b265be9aff2622ae20a0d4c9839ab5a255f3ff41.tar.bz2
gentoo-b265be9aff2622ae20a0d4c9839ab5a255f3ff41.zip
dev-python/python-utils: Bump to 3.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-3.2.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index 77a0c0f32c5a..f72a15bd58e1 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1 +1,2 @@
DIST python-utils-3.1.0.tar.gz 24251 BLAKE2B c00f4c45480f0948cddfa65d4f1ce17ac6831e29b24913d225544619ebedaca67c0f143b55698f8e2edd658e5f90ac39e005a5c29e09d75b5643f79992ba878a SHA512 e22ea0dc7aa0e6c5b45c55843011971c5075639424d38a712703b0d5ef8af32e3661d39af63b6015c4edfe11fca7a256f4f02c3705e1724fe8b9015931d85cbf
+DIST python-utils-3.2.2.tar.gz 25202 BLAKE2B ae36d918bfd125ed1c01a71f8b448390b70071eca8c404f2ce89312c0de8296b29026cd72baa1eeba940d84e2f0b5275ea0ee96735fdecd1b7fb8f5d42ac1b57 SHA512 cd3a9efbd71e33a343de4793c1b415129fbe280ea6b6bc40e84fc1ada7d409139d8bef6c7e2954ef6cd3b9407d817b07a61093d1a8b9de70f6af0b6aba3ebc8d
diff --git a/dev-python/python-utils/python-utils-3.2.2.ebuild b/dev-python/python-utils/python-utils-3.2.2.ebuild
new file mode 100644
index 000000000000..ce049eb48c18
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="
+ https://github.com/WoLpH/python-utils/
+ https://pypi.org/project/python-utils/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+ _python_utils_tests/test_logger.py
+ python_utils/loguru.py
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}