summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-virtkey
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-virtkey')
-rw-r--r--dev-python/python-virtkey/Manifest1
-rw-r--r--dev-python/python-virtkey/metadata.xml8
-rw-r--r--dev-python/python-virtkey/python-virtkey-0.60.0-r1.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-virtkey/Manifest b/dev-python/python-virtkey/Manifest
new file mode 100644
index 000000000000..7d9a89a5f48d
--- /dev/null
+++ b/dev-python/python-virtkey/Manifest
@@ -0,0 +1 @@
+DIST python-virtkey-0.60.0.tar.gz 40328 SHA256 f8de93ded985454484e6d2e52ce86b4c7aae65bc3cd97fc8aa7259def2a091a1 SHA512 96e48fd5ab861d5bccc40dfed1b71c7ea5ce01aeafaa5b1a58ba7a0250dfe191eab35ef0a95f247e64ea49213a20cc596bbfd64e091fd4624daae38edba2840b WHIRLPOOL 2d61955c3e8e8a256f6ca142e4314597de4a324eff46d0f783340fd6123af5bb16b1383ffa421999a89a68f1a9979b801870b81d31f9bbc6fc20d5fd3b8e4f33
diff --git a/dev-python/python-virtkey/metadata.xml b/dev-python/python-virtkey/metadata.xml
new file mode 100644
index 000000000000..dcf1228fcdbe
--- /dev/null
+++ b/dev-python/python-virtkey/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-accessibility</herd>
+ <upstream>
+ <remote-id type="launchpad">python-virtkey</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-virtkey/python-virtkey-0.60.0-r1.ebuild b/dev-python/python-virtkey/python-virtkey-0.60.0-r1.ebuild
new file mode 100644
index 000000000000..8ddd4648e36a
--- /dev/null
+++ b/dev-python/python-virtkey/python-virtkey-0.60.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python module to simulate keypresses and get current keyboard layout"
+HOMEPAGE="https://launchpad.net/virtkey"
+SRC_URI="http://launchpad.net/python-virtkey/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2[${PYTHON_USEDEP}]
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}