summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-07-19 11:13:48 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-07-19 11:14:08 +0300
commita9a375bce3ed814323156e9c1f8865587265ca06 (patch)
treec94d98cf5e7bc66287ca0d9c9d289cf1388488eb /dev-python/python3-lxc
parentapp-arch/libarchive: Bump to 3.7.0 (diff)
downloadgentoo-a9a375bce3ed814323156e9c1f8865587265ca06.tar.gz
gentoo-a9a375bce3ed814323156e9c1f8865587265ca06.tar.bz2
gentoo-a9a375bce3ed814323156e9c1f8865587265ca06.zip
dev-python/python3-lxc: update EAPI 7 -> 8
Closes: https://bugs.gentoo.org/909960 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/python3-lxc')
-rw-r--r--dev-python/python3-lxc/python3-lxc-3.0.4-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python3-lxc/python3-lxc-3.0.4-r1.ebuild b/dev-python/python3-lxc/python3-lxc-3.0.4-r1.ebuild
new file mode 100644
index 000000000000..acc9c25848b0
--- /dev/null
+++ b/dev-python/python3-lxc/python3-lxc-3.0.4-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 verify-sig
+
+DESCRIPTION="Python bindings for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxc/"
+SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz
+ verify-sig? ( https://linuxcontainers.org/downloads/lxc/${P}.tar.gz.asc )"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="verify-sig"
+
+RDEPEND="app-containers/lxc"
+BDEPEND="virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-linuxcontainers )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc