summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:47:43 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commitbc4aca4225d07877c9d3d77579e2e7c0ccd17456 (patch)
tree6f9a54adfb09e6ed526df9ec3dde4f33fe528cee /dev-python/pytz
parentdev-python/unittest2: Add python3.5 support (diff)
downloadgentoo-bc4aca4225d07877c9d3d77579e2e7c0ccd17456.tar.gz
gentoo-bc4aca4225d07877c9d3d77579e2e7c0ccd17456.tar.bz2
gentoo-bc4aca4225d07877c9d3d77579e2e7c0ccd17456.zip
dev-python/pytz: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pytz')
-rw-r--r--dev-python/pytz/pytz-2015.6-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytz/pytz-2015.6-r1.ebuild b/dev-python/pytz/pytz-2015.6-r1.ebuild
new file mode 100644
index 000000000000..5913f36bc8b9
--- /dev/null
+++ b/dev-python/pytz/pytz-2015.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="http://pythonhosted.org/pytz/ https://pypi.python.org/pypi/pytz/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=sys-libs/timezone-data-2014i"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}"/${PN}-2009j-zoneinfo.patch
+ # ...and do not install a copy of it.
+ "${FILESDIR}"/${PN}-2009h-zoneinfo-noinstall.patch
+)
+
+python_test() {
+ "${PYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
+}