summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:44:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:55:02 +0200
commit4ccf19f776fada8ff9513206a416e07bf5abc283 (patch)
treededa519bbd9b54a7589b4e3cfe5dc4b57edb20d5 /dev-python/pyu2f
parentdev-python/pytz: Remove redundant versions (diff)
downloadgentoo-4ccf19f776fada8ff9513206a416e07bf5abc283.tar.gz
gentoo-4ccf19f776fada8ff9513206a416e07bf5abc283.tar.bz2
gentoo-4ccf19f776fada8ff9513206a416e07bf5abc283.zip
dev-python/pyu2f: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyu2f')
-rw-r--r--dev-python/pyu2f/pyu2f-0.1.4.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/pyu2f/pyu2f-0.1.4.ebuild b/dev-python/pyu2f/pyu2f-0.1.4.ebuild
deleted file mode 100644
index ac8c32eb58a1..000000000000
--- a/dev-python/pyu2f/pyu2f-0.1.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python based U2F host library"
-HOMEPAGE="https://github.com/google/pyu2f"
-# pypi tarball lacks unit tests
-#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
-SRC_URI="https://github.com/google/pyu2f/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pyfakefs[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CONTRIBUTING.md README.md )
-
-python_prepare_all() {
- sed -e 's:json.loads(communicate_json):json.loads(communicate_json.decode()):' \
- -i pyu2f/tests/customauthenticator_test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v pyu2f/tests || die "Tests failed under ${EPYTHON}"
-}