summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/qrcode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/qrcode')
-rw-r--r--dev-python/qrcode/Manifest2
-rw-r--r--dev-python/qrcode/metadata.xml8
-rw-r--r--dev-python/qrcode/qrcode-5.0.1.ebuild30
-rw-r--r--dev-python/qrcode/qrcode-5.1.ebuild38
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/qrcode/Manifest b/dev-python/qrcode/Manifest
new file mode 100644
index 000000000000..043dff7dcc48
--- /dev/null
+++ b/dev-python/qrcode/Manifest
@@ -0,0 +1,2 @@
+DIST qrcode-5.0.1.tar.gz 20546 SHA256 5ce16060c2c4f9fc9455bc82766c227e55ee9b43bfb9f17bfe3f1f5ba5eecf3c SHA512 a57ca9d4b382637a8b3cc3a20a03d291f22675e9d851a739f01c610465f1977efd748661330557e9017db2d7b9b501c278668da5eeef93fb8e503e71921bb4c5 WHIRLPOOL d4e55f2536a917bd5f040f2cb66cabe2a529e5a9266fd09d0f413ba0a3137dffc89afd4d32ac4db2f8bbf6db17a1ecccf6bf8ba08d7a188b924daa778491c727
+DIST qrcode-5.1.tar.gz 22259 SHA256 33bdee5e834fc99eb538e1dad198a3a5b70d0a88845629cacf4c592be1ce7f6a SHA512 67a7bb51fe2386f3b1ac0b799d3850d3ca4f61286fdc809654df3f5a1071b503707a9a3e82e595b7611dd9d7b7e74b36e19b86942fb5ad94c256cd7ca9aa02f3 WHIRLPOOL df72f727af2a1342adf61fcde25645cd25f5cfafd454ae2d13567a3c144949738f924082fe78dbb529c9b3757bbf1474e5f4f48fc95538d5d1cdcfdc6452637d
diff --git a/dev-python/qrcode/metadata.xml b/dev-python/qrcode/metadata.xml
new file mode 100644
index 000000000000..76d59aacfa6a
--- /dev/null
+++ b/dev-python/qrcode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">qrcode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/qrcode/qrcode-5.0.1.ebuild b/dev-python/qrcode/qrcode-5.0.1.ebuild
new file mode 100644
index 000000000000..85829571ffea
--- /dev/null
+++ b/dev-python/qrcode/qrcode-5.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="QR Code generator on top of PIL"
+HOMEPAGE="https://pypi.python.org/pypi/qrcode"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# optional deps:
+# - dev-python/lxml for svg backend
+# - virtual/pil for PIL backend
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${PYTHON}" -m unittest qrcode.tests || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/qrcode/qrcode-5.1.ebuild b/dev-python/qrcode/qrcode-5.1.ebuild
new file mode 100644
index 000000000000..a9bbb7b55022
--- /dev/null
+++ b/dev-python/qrcode/qrcode-5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="QR Code generator on top of PIL"
+HOMEPAGE="https://pypi.python.org/pypi/qrcode"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+# optional deps:
+# - pillow and lxml for svg backend, set as hard deps
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+python_test() {
+ "${PYTHON}" -m unittest discover > /dev/tty | less || die "Testing failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/qr.1
+}