summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-11-08 10:50:42 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-11-12 14:18:09 +0100
commitd84f53a8c41b8fc9684e0d33b39ff2a949524487 (patch)
treea679f0f3ea95ca7ce197a1d40cb73fbe99b57a69 /dev-python/qtconsole
parentdev-games/tiled: version bump (diff)
downloadgentoo-d84f53a8c41b8fc9684e0d33b39ff2a949524487.tar.gz
gentoo-d84f53a8c41b8fc9684e0d33b39ff2a949524487.tar.bz2
gentoo-d84f53a8c41b8fc9684e0d33b39ff2a949524487.zip
dev-python/qtconsole: Fix test dependencies.
Gentoo-Bug: https://bugs.gentoo.org/598659 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2775 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/qtconsole-4.1.1.ebuild9
-rw-r--r--dev-python/qtconsole/qtconsole-4.2.1.ebuild7
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-python/qtconsole/qtconsole-4.1.1.ebuild b/dev-python/qtconsole/qtconsole-4.1.1.ebuild
index a7c0411f2e34..5c5587cebdb5 100644
--- a/dev-python/qtconsole/qtconsole-4.1.1.ebuild
+++ b/dev-python/qtconsole/qtconsole-4.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,11 +29,16 @@ DEPEND="${RDEPEND}
)
test? (
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
+ || (
+ dev-python/pyside[${PYTHON_USEDEP},svg]
+ dev-python/PyQt5[${PYTHON_USEDEP},svg,testlib]
+ dev-python/PyQt4[${PYTHON_USEDEP},svg,testlib]
+ )
)
|| (
dev-python/pyside[${PYTHON_USEDEP},svg]
- dev-python/PyQt4[${PYTHON_USEDEP},svg]
dev-python/PyQt5[${PYTHON_USEDEP},svg]
+ dev-python/PyQt4[${PYTHON_USEDEP},svg]
)
dev-python/pygments[${PYTHON_USEDEP}]
>=dev-python/pyzmq-13[${PYTHON_USEDEP}]
diff --git a/dev-python/qtconsole/qtconsole-4.2.1.ebuild b/dev-python/qtconsole/qtconsole-4.2.1.ebuild
index 378cd202ed65..afeb182c9012 100644
--- a/dev-python/qtconsole/qtconsole-4.2.1.ebuild
+++ b/dev-python/qtconsole/qtconsole-4.2.1.ebuild
@@ -29,11 +29,16 @@ DEPEND="${RDEPEND}
)
test? (
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
+ || (
+ dev-python/pyside[${PYTHON_USEDEP},svg]
+ dev-python/PyQt5[${PYTHON_USEDEP},svg,testlib]
+ dev-python/PyQt4[${PYTHON_USEDEP},svg,testlib]
+ )
)
|| (
dev-python/pyside[${PYTHON_USEDEP},svg]
- dev-python/PyQt4[${PYTHON_USEDEP},svg]
dev-python/PyQt5[${PYTHON_USEDEP},svg]
+ dev-python/PyQt4[${PYTHON_USEDEP},svg]
)
dev-python/pygments[${PYTHON_USEDEP}]
>=dev-python/pyzmq-13[${PYTHON_USEDEP}]