summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-17 00:13:25 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-18 20:10:24 +0000
commit8cdcf993802b475190ed990974d7cb3241dd9b6f (patch)
treea44eac5ec6f76cca90a2b63129f512f91a9d0565 /dev-python/reproject
parentsci-libs/hdf5: switched to virtual/szip (diff)
downloadgentoo-8cdcf993802b475190ed990974d7cb3241dd9b6f.tar.gz
gentoo-8cdcf993802b475190ed990974d7cb3241dd9b6f.tar.bz2
gentoo-8cdcf993802b475190ed990974d7cb3241dd9b6f.zip
dev-python/reproject: initial import
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/reproject')
-rw-r--r--dev-python/reproject/Manifest1
-rw-r--r--dev-python/reproject/metadata.xml20
-rw-r--r--dev-python/reproject/reproject-0.2.ebuild43
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/reproject/Manifest b/dev-python/reproject/Manifest
new file mode 100644
index 000000000000..5364251f0446
--- /dev/null
+++ b/dev-python/reproject/Manifest
@@ -0,0 +1 @@
+DIST reproject-0.2.tar.gz 622834 SHA256 6d1b248936ab1f14ecdd3498a5a074318e1b956c90f3e9df7acf8aa77a2af24a SHA512 b4b20d39a1ceb6ee64e4460a819cd4cb1ccceba3462276404e7b294e993a2fd8306c283f397315947826a0343b1a179ff733b49d8afbd96255633a5459bf3ec3 WHIRLPOOL d2d80d22637da94a93467a9d0ada959cf9b80a79b2ee2f3d805a7d5e3c4997622aef02e1f59134934c6b81405483f0009296e7fb597f015267e565f8ac2f6897
diff --git a/dev-python/reproject/metadata.xml b/dev-python/reproject/metadata.xml
new file mode 100644
index 000000000000..7a7ae6566090
--- /dev/null
+++ b/dev-python/reproject/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a package to reproject astronomical images using various techniques
+ via a uniform interface. Reprojection means the re-gridding of images from
+ one world coordinate system to another (for example changing the pixel
+ resolution, orientation, coordinate system). Currently implemented are
+ reprojection of celestial images by interpolation, as well as by finding the
+ exact overlap between pixels on the celestial sphere. It can also reproject
+ to/from HEALPIX projections.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">reproject</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/reproject/reproject-0.2.ebuild b/dev-python/reproject/reproject-0.2.ebuild
new file mode 100644
index 000000000000..aac59ac285a6
--- /dev/null
+++ b/dev-python/reproject/reproject-0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Reproject astronomical images with Python"
+HOMEPAGE="http://reproject.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx -w
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/ )
+ distutils-r1_python_install_all
+}