summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 18:33:32 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 18:39:15 -0500
commite8b42125f2e61da55af02596e1bdaf3b5a9762a1 (patch)
tree2f9eaa34da6c3d2b78b5574573037f5c293c213b /dev-python/requestsexceptions
parentsci-geosciences/googleearth: Regenerate Manifest file. (diff)
downloadgentoo-e8b42125f2e61da55af02596e1bdaf3b5a9762a1.tar.gz
gentoo-e8b42125f2e61da55af02596e1bdaf3b5a9762a1.tar.bz2
gentoo-e8b42125f2e61da55af02596e1bdaf3b5a9762a1.zip
dev-python/requestsexceptions: adding for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/requestsexceptions')
-rw-r--r--dev-python/requestsexceptions/Manifest1
-rw-r--r--dev-python/requestsexceptions/metadata.xml11
-rw-r--r--dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild22
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/requestsexceptions/Manifest b/dev-python/requestsexceptions/Manifest
new file mode 100644
index 000000000000..10a2f2170e87
--- /dev/null
+++ b/dev-python/requestsexceptions/Manifest
@@ -0,0 +1 @@
+DIST requestsexceptions-1.1.3.tar.gz 6606 SHA256 d678b872f51f76d875e00e6667f4ddbf013b3a99490ae5fe07cf3e4f846e283e SHA512 33a848b04db500b3481b7df2553e244e1967e5124de1606f73fb38f0b2681253ca2bd921386ce50f1144a8dc8d6f8e07be058a3d9f13c7831f77cade0a42fd38 WHIRLPOOL b806c364b25b05a7659062a92cb1cf5131ebeee1fff2539d1e898d4294595eb4c0d91736a88e05c99b49b0d4d3f984189574055b6aae9e95b302cd9c002d3ba5
diff --git a/dev-python/requestsexceptions/metadata.xml b/dev-python/requestsexceptions/metadata.xml
new file mode 100644
index 000000000000..0b67aa27ba14
--- /dev/null
+++ b/dev-python/requestsexceptions/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ The python requests library bundles the urllib3 library, however, some software distributions modify requests to remove the bundled library. This makes some operations, such as supressing the "insecure platform warning" messages that urllib emits difficult. This is a simple library to find the correct path to exceptions in the requests library regardless of whether they are bundled.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild b/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild
new file mode 100644
index 000000000000..699e009aed55
--- /dev/null
+++ b/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Finds the correct path to exceptions in the requests library."
+HOMEPAGE="https://github.com/openstack-infra/requestsexceptions"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"