summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 09:17:00 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 09:30:59 +0200
commit1757cbd805e05e73809bdfe4c74e40bd45502dcc (patch)
tree344760a266dac29c7f5db7af521b96b881af3c6b /dev-python/rope
parentdev-python/roman: Remove redundant versions (diff)
downloadgentoo-1757cbd805e05e73809bdfe4c74e40bd45502dcc.tar.gz
gentoo-1757cbd805e05e73809bdfe4c74e40bd45502dcc.tar.bz2
gentoo-1757cbd805e05e73809bdfe4c74e40bd45502dcc.zip
dev-python/rope: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/files/rope-0.10.3-doc-syntax-errors.patch35
-rw-r--r--dev-python/rope/rope-0.10.7.ebuild46
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index c210a442a215..fda0302a1dd6 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,2 +1 @@
-DIST rope-0.10.7.tar.gz 244089 BLAKE2B aebc1eaa3715aa4f2423490790f53040ad256fca35b3ad7b516e6b1f0af051b79f812f7b701ff5ac2414dbf2d1cba319da0f4cf241041329c0c750ae63e0ec33 SHA512 80343b8b7af883afbd04734b0fe4dbdab114301234654cbd95b3ae8be8dff40878105b7647209f5e899b981ab6a7ecb987d9bdf942b32ed083c745128c22ef95
DIST rope-0.16.0.tar.gz 243304 BLAKE2B 2c41572687ef245eb20abfccebcc9f12ecaa177be313cec59c85be5102b7358566570730a7140f952b0a1c515b479c3d21740d32d4678e65c4c572acf86f4e27 SHA512 33ba57b246337e413126309a521c54e861899b03fd250e148b97d9789cddf6eceab36609ea6e36e84ad1ac514bc3363f4937b01bcb96b6103c2a33bec1d4fb75
diff --git a/dev-python/rope/files/rope-0.10.3-doc-syntax-errors.patch b/dev-python/rope/files/rope-0.10.3-doc-syntax-errors.patch
deleted file mode 100644
index f219e1bb02ad..000000000000
--- a/dev-python/rope/files/rope-0.10.3-doc-syntax-errors.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-# Fix syntax errors in doc files
-diff --git a/docs/contributing.rst b/docs/contributing.rst
-index c6cb8a8..9efc3cc 100644
---- a/docs/contributing.rst
-+++ b/docs/contributing.rst
-@@ -45,7 +45,7 @@ about them, don't hesitate to discuss it in the mailing list.
- Getting Ready For Python 3.0
- ----------------------------
-
--Checkout http://bitbucket.org/agr/rope_py3k Mercurial_ repository.
-+Checkout http://bitbucket.org/agr/rope_py3k Mercurial repository.
- Contributions are welcome.
-
- Write Plugins For Other IDEs
-@@ -79,7 +79,7 @@ Source Repository
- =================
-
- Rope uses GitHub_. The repository exists at
--`https://github.com/python-rope/rope`_.
-+`https://github.com/python-rope/rope`.
-
-
- Submitting patches
-diff --git a/docs/library.rst b/docs/library.rst
-index 390b9c8..ee918bc 100644
---- a/docs/library.rst
-+++ b/docs/library.rst
-@@ -72,7 +72,7 @@ In rope, files and folders in a project are accessed through
- ``Change``\s (we'll talk about them later) use resources.
-
- There are two options for creating a ``Resource`` for a path in a project.
--The first approach uses the `Project.get_resource()`_ method.
-+The first approach uses the `Project.get_resource()` method.
-
- .. code-block:: python
diff --git a/dev-python/rope/rope-0.10.7.ebuild b/dev-python/rope/rope-0.10.7.ebuild
deleted file mode 100644
index 9e15a0c71b81..000000000000
--- a/dev-python/rope/rope-0.10.7.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python refactoring library"
-HOMEPAGE="https://github.com/python-rope/rope"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="!dev-python/rope_py3k"
-# Dependency for docbuild documentation which is not noted in
-# setup.py, using standard docutils builds docs successfully.
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}/${PN}-0.10.3-doc-syntax-errors.patch" )
-
-python_test() {
- PYTHONPATH="${BUILD_DIR}/lib:." ${EPYTHON} ropetest/__init__.py
-}
-
-python_compile_all() {
- if use doc; then
- pushd docs > /dev/null || die
- mkdir build || die
- local i
- for i in ./*.rst; do
- rst2html.py $i > ./build/${i/rst/html} || die
- done
- popd > /dev/null || die
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/. )
- distutils-r1_python_install_all
-}