summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-19 09:11:41 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-19 16:02:40 +0200
commit7f4c2c8909f0516d49c4e4e0c530f8382cc2e272 (patch)
treeafdca3bc711502bbd82aac84c63ae14275be1f47 /dev-python/rospkg
parentdev-python/rospkg: add 1.4.0 (diff)
downloadgentoo-7f4c2c8909f0516d49c4e4e0c530f8382cc2e272.tar.gz
gentoo-7f4c2c8909f0516d49c4e4e0c530f8382cc2e272.tar.bz2
gentoo-7f4c2c8909f0516d49c4e4e0c530f8382cc2e272.zip
dev-python/rospkg: update live ebuild
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rospkg')
-rw-r--r--dev-python/rospkg/rospkg-9999.ebuild31
1 files changed, 15 insertions, 16 deletions
diff --git a/dev-python/rospkg/rospkg-9999.ebuild b/dev-python/rospkg/rospkg-9999.ebuild
index fbd4db374f38..430b4a135478 100644
--- a/dev-python/rospkg/rospkg-9999.ebuild
+++ b/dev-python/rospkg/rospkg-9999.ebuild
@@ -1,23 +1,19 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
-fi
-
-inherit ${SCM} distutils-r1
+inherit distutils-r1
DESCRIPTION="Standalone Python library for the ROS package system"
HOMEPAGE="https://wiki.ros.org/rospkg"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- # Needed for tests
+
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+ inherit git-r3
+
S="${WORKDIR}/${PN}"
EGIT_CHECKOUT_DIR="${S}"
else
@@ -28,7 +24,8 @@ fi
LICENSE="BSD"
SLOT="0"
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
"
@@ -37,6 +34,8 @@ BDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
)
"
-PATCHES=( "${FILESDIR}/gentoo.patch" "${FILESDIR}/yaml_load.patch" )
+PATCHES=(
+ "${FILESDIR}/gentoo.patch"
+)
-distutils_enable_tests nose
+distutils_enable_tests pytest