summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-22 10:32:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-22 10:40:54 +0200
commit7bf8b34cfc8c026c705b22ef61fde706618a139d (patch)
treea12291f15218d3e66a236777ea238792b05234af /dev-python/routes
parentdev-python/repoze-lru: Enable py3.11 (diff)
downloadgentoo-7bf8b34cfc8c026c705b22ef61fde706618a139d.tar.gz
gentoo-7bf8b34cfc8c026c705b22ef61fde706618a139d.tar.bz2
gentoo-7bf8b34cfc8c026c705b22ef61fde706618a139d.zip
dev-python/routes: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/Manifest2
-rw-r--r--dev-python/routes/routes-2.5.1-r1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/routes/Manifest b/dev-python/routes/Manifest
index 319143004d09..1d24ad8f29b6 100644
--- a/dev-python/routes/Manifest
+++ b/dev-python/routes/Manifest
@@ -1 +1,3 @@
DIST Routes-2.5.1.tar.gz 190905 BLAKE2B e1498d0a26c7ebb1ee423ad211221f648d5bab4d37effac8c34a5f5189558a62c3ab34780f98f6a1620a261efc6085afd54f0827ac0e7a80217de7ae2226580a SHA512 06ec9a8426ced86524096703de47e3da2fa08bd0ed8c962d451b4338966804245b5074077021fb58a5afcb63acd6dcffa05a89703b8b54841a69a4cdff12b755
+DIST routes-2.5.1-pytest.patch 229759 BLAKE2B 826a053e82b5cae9996c73c56948b24b8c508b33440c60aea62d8d2dfa6461a43377ee1748c8852dd8c2527b0666e9c4c64e38eeaea22fc67ee9291ddcdffb6d SHA512 e6dba07207bf52b931e2369ad32450ebbfbc26571502b9b827b6200f4ce7cfc7b784e4685f9f11472bed63b3711af10ed9833eda35003cc2010924eeeaae4235
+DIST routes-2.5.1.gh.tar.gz 198777 BLAKE2B ca3487af94677889c5249b501fc6dc07e155dd4a862df4f1c8391154598a343ee35b7e8be2b5200bdb234b606a837c471af806c9dc8aa39796b4f4db04bbb164 SHA512 939aebac11f5499ea5c4009e016c52b8b161e7d67c4a540cdbf456cb3db5aec80a4054e7bec9862aaaa02559b081b09cf699c6508e1ac9acffbc5706acd56f30
diff --git a/dev-python/routes/routes-2.5.1-r1.ebuild b/dev-python/routes/routes-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..70515fb8a926
--- /dev/null
+++ b/dev-python/routes/routes-2.5.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A re-implementation of Rails routes system, mapping URLs to Controllers/Actions"
+HOMEPAGE="
+ https://routes.readthedocs.io/en/latest/
+ https://github.com/bbangert/routes/
+ https://pypi.org/project/Routes/
+"
+SRC_URI="
+ https://github.com/bbangert/routes/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/bbangert/routes/pull/107.patch
+ -> ${P}-pytest.patch
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${DISTDIR}/${P}-pytest.patch"
+)
+
+src_prepare() {
+ distutils-r1_src_prepare
+ find tests -name '__init__.py' -delete || die
+}