summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-05 06:36:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-05 06:36:26 +0200
commit9cd2ef47ba8c0a96928dd3e023ef184c45f75008 (patch)
tree7748fa0f78dbff593c9dac3cbcc710a1ced8d192 /dev-python/schema
parentdev-python/pygments: Bump to 2.18.0 (diff)
downloadgentoo-9cd2ef47ba8c0a96928dd3e023ef184c45f75008.tar.gz
gentoo-9cd2ef47ba8c0a96928dd3e023ef184c45f75008.tar.bz2
gentoo-9cd2ef47ba8c0a96928dd3e023ef184c45f75008.zip
dev-python/schema: Bump to 0.7.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/schema')
-rw-r--r--dev-python/schema/Manifest1
-rw-r--r--dev-python/schema/schema-0.7.7.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/schema/Manifest b/dev-python/schema/Manifest
index 49a96927b6b7..4fbd6daf3cef 100644
--- a/dev-python/schema/Manifest
+++ b/dev-python/schema/Manifest
@@ -1 +1,2 @@
DIST schema-0.7.5.tar.gz 48173 BLAKE2B 3d112ee1960c79a64ec2980cbd70403b6dbcafdeeb4f5826c427426aafd602691fd5ceab408edf88e50854a7d66306a73a4729c056a1ca7d1eaa4d0c725901a9 SHA512 10184a4d2a30600d5c6fe9fcde33925137825e811af691c40fee841f88e4a5106ef7e79be2a0ddddd0e0b74892bf889c3d2eff934a36dbca269cd7bf22748d39
+DIST schema-0.7.7.tar.gz 44245 BLAKE2B c984f5948b5f87eafe45cee42b927a61ea7b3fc1877474f189abf448f95be37d299720d1fe72b46d4a24760758c39818c966cef581df48fbf365b9754bcf7167 SHA512 9c811f5c4e87a123a5a1401b6e4b1ff5319f044458fa2b280740dbe78e76661ae868643f0c8a4b738161be6d8ad575401841a824df6664825a545aa0339815c2
diff --git a/dev-python/schema/schema-0.7.7.ebuild b/dev-python/schema/schema-0.7.7.ebuild
new file mode 100644
index 000000000000..61220e35ea2b
--- /dev/null
+++ b/dev-python/schema/schema-0.7.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple data validation library"
+HOMEPAGE="
+ https://github.com/keleshev/schema/
+ https://pypi.org/project/schema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest