summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-06-27 11:53:43 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-06-27 11:53:43 -0700
commit852a312f7cea343a2ada68e427171954ca56b420 (patch)
tree795fc910ead9c84abc9a807ed0b51092472cec89 /dev-python/scipy
parentsys-kernel/gentoo-sources: add back 5.10.216 (diff)
downloadgentoo-852a312f7cea343a2ada68e427171954ca56b420.tar.gz
gentoo-852a312f7cea343a2ada68e427171954ca56b420.tar.bz2
gentoo-852a312f7cea343a2ada68e427171954ca56b420.zip
dev-python/scipy: Filter LTO with numpy-2.0.0 (bug #932721)
Bug: https://bugs.gentoo.org/932721 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/scipy-1.14.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/scipy/scipy-1.14.0.ebuild b/dev-python/scipy/scipy-1.14.0.ebuild
index a37f5c5245cb..6d117893f18d 100644
--- a/dev-python/scipy/scipy-1.14.0.ebuild
+++ b/dev-python/scipy/scipy-1.14.0.ebuild
@@ -9,7 +9,7 @@ DISTUTILS_USE_PEP517=meson-python
PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
-inherit fortran-2 distutils-r1
+inherit flag-o-matic fortran-2 distutils-r1
DESCRIPTION="Scientific algorithms library for Python"
HOMEPAGE="
@@ -95,6 +95,9 @@ python_configure_all() {
-Duse-pythran=$(usex fortran true false)
)
+ # https://bugs.gentoo.org/932721
+ has_version '>=dev-python/numpy-2.0.0' && filter-lto
+
# hide real scipy, to prevent pythran crashing when scipy is being
# rebuilt for new numpy ABI
# https://github.com/serge-sans-paille/pythran/issues/2194