summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-30 14:53:27 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-30 23:51:37 -0400
commitb97c692bdf00d06a3eace3c2aea88b5b9bc9d46a (patch)
treee6ea509bc5733630fc1901fd76b9aaecc6a58571 /dev-python/scipy
parentsys-apps/yarn: drop old (diff)
downloadgentoo-b97c692bdf00d06a3eace3c2aea88b5b9bc9d46a.tar.gz
gentoo-b97c692bdf00d06a3eace3c2aea88b5b9bc9d46a.tar.bz2
gentoo-b97c692bdf00d06a3eace3c2aea88b5b9bc9d46a.zip
dev-python/scipy: remove outdated workaround for pythran
The upstream issue was fixed and released in 0.16, which is also the only version we package anymore. Bump the dependency to make sure people actually updated this bdep, and drop our hack. This also fixes the problem where people misdiagnose a faulty personal environment as a portage bug, due to setting PYTHONPATH="". Well... actually it may hide the issue entirely, if scipy.signal as the `signal` module doesn't actually get used. :) But that is beside the point. Bug: https://bugs.gentoo.org/936948 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/scipy-1.14.0.ebuild14
1 files changed, 1 insertions, 13 deletions
diff --git a/dev-python/scipy/scipy-1.14.0.ebuild b/dev-python/scipy/scipy-1.14.0.ebuild
index cd7be229a991..d92a8af88f7a 100644
--- a/dev-python/scipy/scipy-1.14.0.ebuild
+++ b/dev-python/scipy/scipy-1.14.0.ebuild
@@ -67,7 +67,7 @@ BDEPEND="
virtual/pkgconfig
doc? ( app-arch/unzip )
fortran? (
- >=dev-python/pythran-0.14.0[${PYTHON_USEDEP}]
+ >=dev-python/pythran-0.16.0[${PYTHON_USEDEP}]
)
test? (
>=dev-python/hypothesis-6.30[${PYTHON_USEDEP}]
@@ -97,18 +97,6 @@ python_configure_all() {
# https://bugs.gentoo.org/932721
has_version '>=dev-python/numpy-2.0.0' && filter-lto
-
- # hide real scipy, to prevent pythran crashing when scipy is being
- # rebuilt for new numpy ABI
- # https://github.com/serge-sans-paille/pythran/issues/2194
- cat >> "${T}/scipy.py" <<-EOF || die
- raise ImportError("hide real scipy")
- EOF
-}
-
-python_compile() {
- local -x PYTHONPATH="${T}${PYTHONPATH+:${PYTHONPATH}}"
- distutils-r1_python_compile
}
python_test() {