summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-11 20:59:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-11 22:18:36 +0100
commit0da76b00d8887706d6f28f8b7b74e61afa8fb5a1 (patch)
tree850f821c1d76a9b559bc829f30e880f9dd83a247 /dev-python/sentry-sdk
parentdev-python/pdm-pep517: Bump to 0.11.2 (diff)
downloadgentoo-0da76b00d8887706d6f28f8b7b74e61afa8fb5a1.tar.gz
gentoo-0da76b00d8887706d6f28f8b7b74e61afa8fb5a1.tar.bz2
gentoo-0da76b00d8887706d6f28f8b7b74e61afa8fb5a1.zip
dev-python/sentry-sdk: Bump to 1.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.5.5.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 3bf783d2586e..8c7b3580172c 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -2,3 +2,4 @@ DIST sentry-sdk-1.5.1.tar.gz 234143 BLAKE2B 431216c66b195ef7f26fe74d5f2c6e4697d9
DIST sentry-sdk-1.5.2.tar.gz 238538 BLAKE2B b5ec8da91e6eaf76e5501a3e97e6a06f67b6afb887fcc161ca4c5c6750e294cdb2c72eb7f8ff62b06cb27410f580d3a7ce3aa5981282719a4e4eba3892781394 SHA512 5bac6ce88a2a2f9b6269d6c2483568cbb627e7fb338044272785d1fcd574c7772e47c7304bdc3082058883d53d7ca458f65b3ceeb6d7a7fd70b752b335105193
DIST sentry-sdk-1.5.3.tar.gz 239237 BLAKE2B ce519926fd1873d1c94b76816c8e1d4831d0893ca030e7703d0976dd54930847bd4b1ab7f55ec45c0826bf4ae559a4d56e980f280973f660ff02061b02bd47a6 SHA512 47614f77f31aaaf4891da0dcf64c42e8f2bf42a6d776cba92beb5dab4de6ee28e0f65bd47293c14e9b847455293de021420592bb80af4a4e2e52a3bb89e5d869
DIST sentry-sdk-1.5.4.gh.tar.gz 239778 BLAKE2B 383dbc122439a16692fba5ff3a530817b7dc16a4fb6aef1f0353a09e95fadbe2e31015642ef7c5224ea12855a9b0b170d0a64c9dc5471ad978372fe0742d6552 SHA512 2ac725ca91a948f2e6770c2429e444fa97988c8db145728dd202ca86827d9bb101e96a3d8d0d6e4e6a0678b749da1782c068954a1669e019a125e298adfe8d5e
+DIST sentry-sdk-1.5.5.gh.tar.gz 242280 BLAKE2B 8c3bfeb50d19ee23aa430d77ffa10ea77ab579565b6ef85bacae6d0d8952478587c71d62c74e04e6708ed451b70b8903ffa9bdb10fde5e590586a928118d3942 SHA512 ad31754294e7cc1acd9c5b5f6ae454908e3579298494cef7dbcbc01e0b1a2d2036152ffafe50fc4e859a39e56afc2c8167a242de66b44c9416ebb70a4f032e86
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.5.5.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.5.5.ebuild
new file mode 100644
index 000000000000..2dbf073604e3
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.5.5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ )
+
+ epytest
+}