summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/simplegui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/simplegui')
-rw-r--r--dev-python/simplegui/Manifest1
-rw-r--r--dev-python/simplegui/metadata.xml10
-rw-r--r--dev-python/simplegui/simplegui-0.1.0.ebuild31
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/simplegui/Manifest b/dev-python/simplegui/Manifest
new file mode 100644
index 000000000000..d103aad2d885
--- /dev/null
+++ b/dev-python/simplegui/Manifest
@@ -0,0 +1 @@
+DIST simplegui-0.1.0.zip 15821 SHA256 e852bef6a5f799c3f19b78dac6a0a58f3d29773651d0fa26768030ead4d74037 SHA512 b09bad388dfeff4778c4ed1ebaaf9a01a802c023b272a7bce8efe4091e8dbe658a2bcba56663e686cc76cfd907b6b54da7033946ee989b600e4d5269ad43315c WHIRLPOOL 701153e16e540ba8dfc13609cbceb37eac75e061109b9ae7afe677ac60f8ed03c7e2dd8a761a626b786473983f85b822870d9a593b88bc32016d40b0d91d3c17
diff --git a/dev-python/simplegui/metadata.xml b/dev-python/simplegui/metadata.xml
new file mode 100644
index 000000000000..2ccc7474c094
--- /dev/null
+++ b/dev-python/simplegui/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">simplegui</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/simplegui/simplegui-0.1.0.ebuild b/dev-python/simplegui/simplegui-0.1.0.ebuild
new file mode 100644
index 000000000000..c8929d8580b6
--- /dev/null
+++ b/dev-python/simplegui/simplegui-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 )
+PYTHON_REQ_USE="tk"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="Simplified GUI generation using Tkinter"
+HOMEPAGE="http://florian-berger.de/en/software/simplegui"
+SRC_URI="http://static.florian-berger.de/simplegui-0.1.0.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ dev-python/cx_Freeze[${PYTHON_USEDEP}]"
+
+python_compile() {
+ if [[ ${EPYTHON} == python3.* ]]; then
+ 2to3 --no-diffs -w *.py || die
+ fi
+
+ distutils-r1_python_compile
+}