summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-10-21 21:37:27 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-21 21:37:47 +0200
commit5fcb68af09152990241451bad60d0b897b7a4bea (patch)
tree5bc531205b5c8729b0d99dc891c9b852aa003393 /dev-python/simpy
parentdev-python/simpy: Stable for amd64+x86. (diff)
downloadgentoo-5fcb68af09152990241451bad60d0b897b7a4bea.tar.gz
gentoo-5fcb68af09152990241451bad60d0b897b7a4bea.tar.bz2
gentoo-5fcb68af09152990241451bad60d0b897b7a4bea.zip
dev-python/simpy: clean up old.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/simpy')
-rw-r--r--dev-python/simpy/Manifest2
-rw-r--r--dev-python/simpy/simpy-2.3.1-r1.ebuild43
-rw-r--r--dev-python/simpy/simpy-3.0.3.ebuild41
-rw-r--r--dev-python/simpy/simpy-3.0.8.ebuild2
4 files changed, 1 insertions, 87 deletions
diff --git a/dev-python/simpy/Manifest b/dev-python/simpy/Manifest
index 4e480d088e09..052de577625c 100644
--- a/dev-python/simpy/Manifest
+++ b/dev-python/simpy/Manifest
@@ -1,3 +1 @@
-DIST SimPy-2.3.1.tar.gz 6296235 SHA256 7f5ab61409b4fa28d08a7ed8b903eda8195dc3220cb64eb177a7bb62be89e387 SHA512 39b003ba29df70a3b1a13917f2439b523c06a4f0491b1421023697adb52d096aadc281812ae97a0e7b9498dcaab6bf7a3cd42a26dcce5ec67265e0f95884a828 WHIRLPOOL 1eb975c15859322ea02c27ce78cdd27ffe5c5ae7e070447660010f1eaeb9ec43d987b0af07376d459a118d8b61003b36e86ac34c9d6a4faa1100f94d5b9f3d23
-DIST simpy-3.0.3.tar.gz 1695886 SHA256 f1ea029a67bcc58ae88f8e3ce90bd86533a92d791684186ba21d9a0499b54bc9 SHA512 ed494596664b104a467a916ef99e4205af93aa7c4dcb3210fc722ae81e199a5421a9f20fea999d68e5b3c029f14c951e7f0659ead7880c760b9c7b2b64dc19cf WHIRLPOOL d52b1ccbe6b1471dc4db28b9a2d1a73d3710f968a56af0f56cf67bacc477c43238fd636feba5a3f0312e99f93117e39abf77a54a90b458d8b127f240c114a87f
DIST simpy-3.0.8.tar.gz 402664 SHA256 e127921510773f7b6189ab3596362809a37b87b7c2ae298b29ba3a6cca03e677 SHA512 c8c468ab60da1b357a1c62ca516a0cce51c6941f7b7795ee57c905cd8457f5614c5ff1f6d7586c0b9d9148e03251fd4f77b4e2c3c3d438e532e49bc4583fb08b WHIRLPOOL 736b72632cba64f419512fda90565bfe912c120f9bd9647bbe0446d926485819c760c51594e68d6d410f95fbce99ad7a27687cb607030864459cf53ed64036ba
diff --git a/dev-python/simpy/simpy-2.3.1-r1.ebuild b/dev-python/simpy/simpy-2.3.1-r1.ebuild
deleted file mode 100644
index 1e8e98eae583..000000000000
--- a/dev-python/simpy/simpy-2.3.1-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="tk"
-
-inherit distutils-r1
-
-MY_P="${P/simpy/SimPy}"
-
-DESCRIPTION="Simulation in Python is an object-oriented, process-based discrete-event simulation language"
-HOMEPAGE="http://simpy.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}/SimPy-2.3/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- ${PYTHON} -c "import SimPy; SimPy.test()" || die
-}
-
-python_install_all() {
- DOCS=( AUTHORS.txt CHANGES.txt README.txt )
- if use doc; then
- pushd docs > /dev/null || die
- PYTHONPATH=.. emake html && HTML_DOCS=( docs/html/. docs/build/doctrees/. )
- popd > /dev/null || die
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/simpy/simpy-3.0.3.ebuild b/dev-python/simpy/simpy-3.0.3.ebuild
deleted file mode 100644
index 1899aa7e85ce..000000000000
--- a/dev-python/simpy/simpy-3.0.3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-PYTHON_REQ_USE="tk"
-
-inherit distutils-r1
-
-MY_P="${P/simpy/SimPy}"
-
-DESCRIPTION="Simulation in Python is an object-oriented, process-based discrete-event simulation language"
-HOMEPAGE="http://simpy.readthedocs.org/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
- py.test -vv || die
-}
-
-python_install_all() {
- DOCS=( AUTHORS.txt CHANGES.txt README.txt )
- if use doc; then
- pushd docs > /dev/null || die
- PYTHONPATH=.. emake html && HTML_DOCS=( docs/_build/html/. docs/_build/doctrees/. )
- popd > /dev/null || die
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/simpy/simpy-3.0.8.ebuild b/dev-python/simpy/simpy-3.0.8.ebuild
index f47db4fed6cf..3fc85ad861e1 100644
--- a/dev-python/simpy/simpy-3.0.8.ebuild
+++ b/dev-python/simpy/simpy-3.0.8.ebuild
@@ -11,7 +11,7 @@ inherit distutils-r1
MY_P="${P/simpy/SimPy}"
-DESCRIPTION="Simulation in Python is an object-oriented, process-based discrete-event simulation language"
+DESCRIPTION="Object-oriented, process-based discrete-event simulation language"
HOMEPAGE="http://simpy.readthedocs.org/en/latest/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"