summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2020-10-28 07:04:54 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2020-10-28 07:27:35 +0000
commit1c3e5f7ca303b6ccb4b7e5e8170bb3a0d8eb98c0 (patch)
treeae788d89ae6f17330f620de0af929d5ac5a1bdcd /dev-python/slixmpp
parentwww-client/microsoft-edge-dev: new package (diff)
downloadgentoo-1c3e5f7ca303b6ccb4b7e5e8170bb3a0d8eb98c0.tar.gz
gentoo-1c3e5f7ca303b6ccb4b7e5e8170bb3a0d8eb98c0.tar.bz2
gentoo-1c3e5f7ca303b6ccb4b7e5e8170bb3a0d8eb98c0.zip
dev-python/slixmpp: add 9999 live ebuild
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'dev-python/slixmpp')
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
new file mode 100644
index 000000000000..64f1fc02263a
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://lab.louiz.org/poezio/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ net-dns/libidn
+"
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest