summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-17 14:00:15 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-17 14:18:03 +0200
commit5c3a84952fcad5578ca74058d480e60e46fb7ac8 (patch)
treeb04bafab1f99cfe67238842609ae32772487c67a /dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.6.ebuild
parentnet-misc/icaclient: Removed old (diff)
downloadgentoo-5c3a84952fcad5578ca74058d480e60e46fb7ac8.tar.gz
gentoo-5c3a84952fcad5578ca74058d480e60e46fb7ac8.tar.bz2
gentoo-5c3a84952fcad5578ca74058d480e60e46fb7ac8.zip
dev-python/sphinx-aiohttp-theme: Bump to 0.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.6.ebuild')
-rw-r--r--dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.6.ebuild b/dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.6.ebuild
new file mode 100644
index 000000000000..b6446239067b
--- /dev/null
+++ b/dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="${PN#sphinx-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sphinx theme for aiohttp"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-theme"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"