summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-09 17:29:45 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-09 17:30:00 +0200
commit200ec109b7b562c32842a43f05a87acd13e044b5 (patch)
treea01a6df0ad164c7630e59920e487f257ab9529e9 /dev-python/sphinx-panels
parentdev-python/sphinx-multiversion: update EAPI 7 -> 8, pep517, py3.12 (diff)
downloadgentoo-200ec109b7b562c32842a43f05a87acd13e044b5.tar.gz
gentoo-200ec109b7b562c32842a43f05a87acd13e044b5.tar.bz2
gentoo-200ec109b7b562c32842a43f05a87acd13e044b5.zip
dev-python/sphinx-panels: update EAPI 7 -> 8, pep517, py3.12
Closes: https://bugs.gentoo.org/909967 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-panels')
-rw-r--r--dev-python/sphinx-panels/Manifest1
-rw-r--r--dev-python/sphinx-panels/metadata.xml1
-rw-r--r--dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild26
3 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sphinx-panels/Manifest b/dev-python/sphinx-panels/Manifest
index 42606f8a782d..d86ffd4897fc 100644
--- a/dev-python/sphinx-panels/Manifest
+++ b/dev-python/sphinx-panels/Manifest
@@ -1 +1,2 @@
+DIST sphinx-panels-0.6.0.gh.tar.gz 400548 BLAKE2B 685b241ffe839face392950ccaa5c00d5613ee4076a4f8d62fdff32158f2d02c444375b7f656a89d4712f8bf895b937ff9fe650cab98670f03b0c4d75e545f97 SHA512 74064538ff8cd1c7c44b5daeda272217618ed33394694883046972b4262d503e1426e7573d8b49040d4b426651377b89fd4ad2a085f1e62827e7ef51e6912e5f
DIST sphinx-panels-0.6.0.tar.gz 400548 BLAKE2B 685b241ffe839face392950ccaa5c00d5613ee4076a4f8d62fdff32158f2d02c444375b7f656a89d4712f8bf895b937ff9fe650cab98670f03b0c4d75e545f97 SHA512 74064538ff8cd1c7c44b5daeda272217618ed33394694883046972b4262d503e1426e7573d8b49040d4b426651377b89fd4ad2a085f1e62827e7ef51e6912e5f
diff --git a/dev-python/sphinx-panels/metadata.xml b/dev-python/sphinx-panels/metadata.xml
index 737d697e677b..75a31066e3b2 100644
--- a/dev-python/sphinx-panels/metadata.xml
+++ b/dev-python/sphinx-panels/metadata.xml
@@ -12,5 +12,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">sphinx-panels</remote-id>
+ <remote-id type="github">executablebooks/sphinx-panels</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild b/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..20998bfad1ce
--- /dev/null
+++ b/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for creating panels in a grid layout"
+HOMEPAGE="https://github.com/executablebooks/sphinx-panels"
+SRC_URI="https://github.com/executablebooks/sphinx-panels/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? ( dev-python/pytest-regressions[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme