summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-05 22:38:09 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-05 22:50:41 +0100
commit1a13e4bab69b7e1d63da2c1fa012d5f9af855f55 (patch)
tree469075be58deb11f229aec7519cb6c5510fb6b79 /dev-python/sphinxcontrib-bibtex
parentdev-python/pybtex-docutils: Bump to 1.0.0 (diff)
downloadgentoo-1a13e4bab69b7e1d63da2c1fa012d5f9af855f55.tar.gz
gentoo-1a13e4bab69b7e1d63da2c1fa012d5f9af855f55.tar.bz2
gentoo-1a13e4bab69b7e1d63da2c1fa012d5f9af855f55.zip
dev-python/sphinxcontrib-bibtex: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-bibtex')
-rw-r--r--dev-python/sphinxcontrib-bibtex/Manifest1
-rw-r--r--dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.2.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-bibtex/Manifest b/dev-python/sphinxcontrib-bibtex/Manifest
index 8a428f1c4b05..bcea1ca4286a 100644
--- a/dev-python/sphinxcontrib-bibtex/Manifest
+++ b/dev-python/sphinxcontrib-bibtex/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-bibtex-2.0.0.tar.gz 135555 BLAKE2B 8a542ff7895a89a8dbf6b8ed1df3ab4e928b68ce86881819c1fbfafdda626c2e1106f5513832ee09248381c89f54f06d4d1b42f005b1f775b0fbe8962a0a0ff1 SHA512 bffd4cb1ea8d88b947b89f5bd1c55bbb8bbab8679f205216f87f932cc0170d2bbabfbe4ea8d32fb7c980826d3f7c4a20cd49c2fb36f288b5cdc4500ad9ff75cd
+DIST sphinxcontrib-bibtex-2.2.0.tar.gz 96027 BLAKE2B 77ca45e36f1730fa6992cfe41763a34e2a0bcdc99c520412591be3c219dcb7a8af240cc74d08c260548475b88b6cfba24b82e7bad2ab21b24c0e9cb62590792a SHA512 fa78d35f04825f841f757e2708d0ebbd3617a7bf20a893249eaee7e435ff2880ffc8bd23608356904ce41fc11d7fd49bab20f3da501d4a217593c52d99caebaa
diff --git a/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.2.0.ebuild b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.2.0.ebuild
new file mode 100644
index 000000000000..3c3e2d33175d
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for BibTeX style citations"
+HOMEPAGE="https://github.com/mcmtroffaes/sphinxcontrib-bibtex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/oset[${PYTHON_USEDEP}]
+ dev-python/pybtex[${PYTHON_USEDEP}]
+ dev-python/pybtex-docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_test() {
+ pytest -vv test || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}