summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-07-25 01:58:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-25 02:06:59 -0500
commitd93f95f376040e7a939132ea701eaf874f86760d (patch)
tree909924adad441a13d7c9c0f0271a2b24ea689418 /dev-python/stestr
parentdev-python/cliff: add missing keywords for stestr (diff)
downloadgentoo-d93f95f376040e7a939132ea701eaf874f86760d.tar.gz
gentoo-d93f95f376040e7a939132ea701eaf874f86760d.tar.bz2
gentoo-d93f95f376040e7a939132ea701eaf874f86760d.zip
dev-python/stestr: adding keywords for pbr
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/stestr')
-rw-r--r--dev-python/stestr/Manifest1
-rw-r--r--dev-python/stestr/stestr-2.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/stestr/Manifest b/dev-python/stestr/Manifest
index 3d34cdf53645..d68e1140bbc4 100644
--- a/dev-python/stestr/Manifest
+++ b/dev-python/stestr/Manifest
@@ -1 +1,2 @@
DIST stestr-1.1.0.tar.gz 95353 BLAKE2B 70435cec22d56f38fb9d87484b261fd73d79f8ea719ffd67861e2504580d6e2932b762839e44dc4c9e348e448693a80e8173850d800374643bbce15374137c37 SHA512 7490f0982c77190adf97daae965a957fc40d0e418a64fc38ccb50817a7266b06224e61f17ae9c84edfe200417eaab726cf834646bfa2efbac67ea029dea54df1
+DIST stestr-2.1.0.tar.gz 103501 BLAKE2B 6b000b8e3d0a27a18f19510dd8d5de8641223c18ad22a3f90b73619aa41bbe1a51bcedba604ec448282fa41e2ae93b61fdd0e72e603a39730a59400fc15ef007 SHA512 a99d0659da0ca2b86703529df9ef6d135578bd8374a2afcbd10bd96f24f5e6dd1dacd5929d96a083881f1db2a930b039d9045348a0298d84d2480c6c9a75d1f7
diff --git a/dev-python/stestr/stestr-2.1.0.ebuild b/dev-python/stestr/stestr-2.1.0.ebuild
new file mode 100644
index 000000000000..372ba5486727
--- /dev/null
+++ b/dev-python/stestr/stestr-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A parallel Python test runner built around subunit"
+HOMEPAGE="https://github.com/mtreinish/stestr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~s390 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/future[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.8.9[${PYTHON_USEDEP}]"