summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-28 11:11:25 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-28 12:14:31 +0200
commit21e07be0e27c56736aa45bf72deeda2fa4c7018a (patch)
tree68e0e96fc410a318e45a418987512fee465b6ac4 /dev-python/tomlkit
parentdev-python/pylint: Bump to 2.13.2 (diff)
downloadgentoo-21e07be0e27c56736aa45bf72deeda2fa4c7018a.tar.gz
gentoo-21e07be0e27c56736aa45bf72deeda2fa4c7018a.tar.bz2
gentoo-21e07be0e27c56736aa45bf72deeda2fa4c7018a.zip
dev-python/tomlkit: Bump to 0.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.10.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 49ac9d899435..b82cca091295 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1 +1,2 @@
DIST tomlkit-0.10.0.tar.gz 183499 BLAKE2B b9906dea2dd8867dca0208f3ce86b3d587f8504addfe25cf29f9164f50dc12d244010df53791ed01e0e7dd16e71ad77ce22c9ea7a37a6216880059c058f112e8 SHA512 05d03ae71a1d72ca0e03276f2b2530ca9fab7d6f366166a79839c66eaa00b55abb5f70a669ecb4d762dbbd655f10e4c4a373a7683cd781ae034d0910a0c3eccf
+DIST tomlkit-0.10.1.tar.gz 183650 BLAKE2B 373ab028b60503cfb9983a969e97318a61004a8db1bafed32b775e2a26a5557f8493ea9026ac9dbeff707d198c2913c34bf25c7e424345bb6b5ea3aa211e3a4a SHA512 a5082b88a9b3832393d860258dd7584ed05788777d4c1dd98415bfb7c64acf8f77eaf18c3fcf824913d999ffa37b4481675b3fce9b8af8ef9c1be0712ad622a9
diff --git a/dev-python/tomlkit/tomlkit-0.10.1.ebuild b/dev-python/tomlkit/tomlkit-0.10.1.ebuild
new file mode 100644
index 000000000000..4de45e362c79
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.10.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="https://github.com/sdispater/tomlkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # use setup.py to avoid circular dep with poetry-core
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["setuptools", "wheel"]
+ build-backend = "setuptools.build_meta"
+ EOF
+}