summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-07 08:07:09 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-07 08:33:37 +0200
commitacc8020cd2bef65da5da5f2544cb7bfb4945fbc0 (patch)
treea5e6d0332d1d57551fb9cf2b9522f1a1a9bf4cd7 /dev-python/tqdm
parentdev-python/aws-sam-translator: Bump to 1.37.0 (diff)
downloadgentoo-acc8020cd2bef65da5da5f2544cb7bfb4945fbc0.tar.gz
gentoo-acc8020cd2bef65da5da5f2544cb7bfb4945fbc0.tar.bz2
gentoo-acc8020cd2bef65da5da5f2544cb7bfb4945fbc0.zip
dev-python/tqdm: Bump to 4.61.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.61.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index f9785ed38ea3..91e8178c2e3a 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1 +1,2 @@
DIST tqdm-4.61.1.tar.gz 169637 BLAKE2B 8b89f320e13119b24a9e121747bce0b5c6625c31feb8c427a97e71da52797d9de764ce5e5c41c07d5954a1e5e4e21913335a4691837bc243db473821b2dad1ac SHA512 6092a30389380a511abc8bee7e6144556d6dc1a993ba4a2685707afa2838a12f472aa216ac5e55d144da74f9be1d398d4c6f5352986a200557e4aba67831a505
+DIST tqdm-4.61.2.tar.gz 169665 BLAKE2B f5dff67eb549cab0dd667815c25f6e885a2e0cefc2ad68e97fdc09599eb41b13589f7a88d5a445813973454a5e5f835b3139651ec2e09b717db0fd6dc705890e SHA512 bc33e8fe00244f90f61ab51d0c7c0b98d5580efebd9758284d9dbe2a699eabeb0d92871eedc2f95f377e29dd0f7ea4b5247b96cb4cc1687dcfea3a9ed1152ab7
diff --git a/dev-python/tqdm/tqdm-4.61.2.ebuild b/dev-python/tqdm/tqdm-4.61.2.ebuild
new file mode 100644
index 000000000000..376ba7ad0389
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.61.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ epytest --ignore 'tests/tests_perf.py'
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}