summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-04-04 17:25:30 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-05-15 19:07:07 -0700
commit60a8fb88ce08d39ae1148f4992321c8324bc3f59 (patch)
treea6dd8d66f9f6925ad8d227871325b43dbbade12e /dev-python/txrequests
parentsys-apps/openrc: 0.26.2 version bump (diff)
downloadgentoo-60a8fb88ce08d39ae1148f4992321c8324bc3f59.tar.gz
gentoo-60a8fb88ce08d39ae1148f4992321c8324bc3f59.tar.bz2
gentoo-60a8fb88ce08d39ae1148f4992321c8324bc3f59.zip
dev-python/txrequests: rev-bump, add python 3.{4,5,6}
Reduce the twisted dep to only the new single pkg. Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Diffstat (limited to 'dev-python/txrequests')
-rw-r--r--dev-python/txrequests/txrequests-0.9.5-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/txrequests/txrequests-0.9.5-r1.ebuild b/dev-python/txrequests/txrequests-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..6fe8cbaea19f
--- /dev/null
+++ b/dev-python/txrequests/txrequests-0.9.5-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6})
+
+inherit distutils-r1
+
+DESCRIPTION="Asynchronous Python HTTP for Humans"
+HOMEPAGE="https://github.com/tardyp/txrequests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/requests-1.2.0[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"