summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-19 05:59:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-19 05:59:34 +0200
commitd20aacc7370ea716f4802fcf4f2e466e7ecca683 (patch)
treef5ae267ad3e40dde591a3608f11b95f41863cbf6 /dev-python/u-msgpack-python
parentdev-python/simpervisor: Bump to 1.0.0 (diff)
downloadgentoo-d20aacc7370ea716f4802fcf4f2e466e7ecca683.tar.gz
gentoo-d20aacc7370ea716f4802fcf4f2e466e7ecca683.tar.bz2
gentoo-d20aacc7370ea716f4802fcf4f2e466e7ecca683.zip
dev-python/u-msgpack-python: Bump to 2.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/u-msgpack-python')
-rw-r--r--dev-python/u-msgpack-python/Manifest1
-rw-r--r--dev-python/u-msgpack-python/u-msgpack-python-2.8.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/u-msgpack-python/Manifest b/dev-python/u-msgpack-python/Manifest
index a21feccff61e..b17c820034ee 100644
--- a/dev-python/u-msgpack-python/Manifest
+++ b/dev-python/u-msgpack-python/Manifest
@@ -1 +1,2 @@
DIST u-msgpack-python-2.7.2.tar.gz 20654 BLAKE2B 0365e4e778c9979d9154d8a267ba3bdaad9b2ef808723d2ae89e078fc0c8d76aebab234f1723985cf3b288274123e49571607599d6087ea234e3e8dc11e3a302 SHA512 e5d35bc03e5c23cfbaf9cc7f6459576e89b5dd19661ddff2a4ab5de2751e0b73c17e4685c6fead15ce2bf100b2250a3ba7cb10a7fa3f23debfa2141f4370b623
+DIST u-msgpack-python-2.8.0.tar.gz 18167 BLAKE2B 9cd0bf2a7dca8eac4c990e320a5d3c325ea31867c82a46d588c8e9bfae1feef504916f8cb75d3f2ed2adb3fa13c03c07fca91071d5d9a6d6ab47686539d704bf SHA512 61dd332c9f72db65a6a949e2acdc668ab01981b3eb1e9fd58e506d35d47f5f656b9d0abec92ae0e4d949bab063aeff75c205b92758275d99dbbe5f65f15241b9
diff --git a/dev-python/u-msgpack-python/u-msgpack-python-2.8.0.ebuild b/dev-python/u-msgpack-python/u-msgpack-python-2.8.0.ebuild
new file mode 100644
index 000000000000..b58e66e47898
--- /dev/null
+++ b/dev-python/u-msgpack-python/u-msgpack-python-2.8.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A portable, lightweight MessagePack serializer and deserializer"
+HOMEPAGE="
+ https://github.com/vsergeev/u-msgpack-python/
+ https://pypi.org/project/u-msgpack-python/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest