summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-06 00:36:43 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-06 00:41:08 +0000
commit6559c903eb05bd0bdae2a4d356d0260b4e7f1b36 (patch)
treea1991beb7f3037c63d8e2a713255089d98231b49 /dev-python/uncertainties
parentdev-python/gwcs: initial import (diff)
downloadgentoo-6559c903eb05bd0bdae2a4d356d0260b4e7f1b36.tar.gz
gentoo-6559c903eb05bd0bdae2a4d356d0260b4e7f1b36.tar.bz2
gentoo-6559c903eb05bd0bdae2a4d356d0260b4e7f1b36.zip
dev-python/uncertainties: initial import
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/uncertainties')
-rw-r--r--dev-python/uncertainties/Manifest1
-rw-r--r--dev-python/uncertainties/metadata.xml22
-rw-r--r--dev-python/uncertainties/uncertainties-3.0.1.ebuild43
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/uncertainties/Manifest b/dev-python/uncertainties/Manifest
new file mode 100644
index 000000000000..bcf447c4642b
--- /dev/null
+++ b/dev-python/uncertainties/Manifest
@@ -0,0 +1 @@
+DIST uncertainties-3.0.1.tar.gz 225752 SHA256 de0765cac6911e5afa93ee941063a07b4a98dbd9c314c5eea4ab14bfff0054a4 SHA512 d4b2a905665c46224586f5f9702ad9e69580fc5afe8c6c045b04141fdc54e0c402cdee033ee0ee7055823b922bd33c732b3066453876509d45add15abf9d85f5 WHIRLPOOL f203fc2fdae59775dcb57db81ffb3ff02befd50676251c218934fa15f7c7df047d97282d90ac5f9f658d040b173e2aad8fed5130c8158c39fadd7d13b80036df
diff --git a/dev-python/uncertainties/metadata.xml b/dev-python/uncertainties/metadata.xml
new file mode 100644
index 000000000000..a24d72178d1b
--- /dev/null
+++ b/dev-python/uncertainties/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ uncertainties is a Python module, which allows calculations such as
+ .
+ (0.2 +/- 0.01) * 2 = 0.4 +/- 0.02
+ .
+ to be performed transparently; much more complex mathematical expressions
+ involving numbers with uncertainties can also be evaluated transparently.
+ Correlations between expressions are correctly taken into account; x-x is
+ thus exactly zero, for instance. The uncertainties produced by this module
+ are what is predicted by error propagation theory.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">uncertainties</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/uncertainties/uncertainties-3.0.1.ebuild b/dev-python/uncertainties/uncertainties-3.0.1.ebuild
new file mode 100644
index 000000000000..3ef0de8c5060
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="https://pythonhosted.org/uncertainties/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+ppython_compile_all() {
+ if use doc; then
+ PYTHONPATH="${BUILD_DIR}"/lib esetup.py build_sphinx
+ fi
+}
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py build_sphinx
+}
+
+python_test() {
+ esetup.py nosetests -sv || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}