summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-25 21:08:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-25 21:08:48 +0300
commit8bb6bcb07ac41f300d430441a7cb0998fd3f94dc (patch)
treec041387264b729e0be0b10b1c92442219ef01511 /dev-python/uncertainties
parentdev-python/uncertainties: enable py3.10 (diff)
downloadgentoo-8bb6bcb07ac41f300d430441a7cb0998fd3f94dc.tar.gz
gentoo-8bb6bcb07ac41f300d430441a7cb0998fd3f94dc.tar.bz2
gentoo-8bb6bcb07ac41f300d430441a7cb0998fd3f94dc.zip
dev-python/uncertainties: make numpy optional dep
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/uncertainties')
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.6.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.6.ebuild b/dev-python/uncertainties/uncertainties-3.1.6.ebuild
index 79cf80d62910..69090d5bc1f8 100644
--- a/dev-python/uncertainties/uncertainties-3.1.6.ebuild
+++ b/dev-python/uncertainties/uncertainties-3.1.6.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
+inherit distutils-r1 optfeature
DESCRIPTION="Python module for calculations with uncertainties"
HOMEPAGE="https://pythonhosted.org/uncertainties/"
@@ -15,13 +15,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc"
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )
"
distutils_enable_tests nose
@@ -34,3 +31,7 @@ python_install_all() {
use doc && local HTML_DOCS=( build/sphinx/html/. )
distutils-r1_python_install_all
}
+
+pkg_postinst() {
+ optfeature "numpy support" dev-python/numpy
+}