summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 13:58:39 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:18:00 +0100
commit81ae1d7f37c9afc6dee690e2fa9560aac405f902 (patch)
tree0308e463d2bc3f5b2cb5d46217c52623dcc48710 /dev-python/uranium
parentdev-python/thunarx-python: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-81ae1d7f37c9afc6dee690e2fa9560aac405f902.tar.gz
gentoo-81ae1d7f37c9afc6dee690e2fa9560aac405f902.tar.bz2
gentoo-81ae1d7f37c9afc6dee690e2fa9560aac405f902.zip
dev-python/uranium: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uranium')
-rw-r--r--dev-python/uranium/uranium-3.6.0-r1.ebuild18
-rw-r--r--dev-python/uranium/uranium-4.2.0.ebuild18
-rw-r--r--dev-python/uranium/uranium-4.3.0-r1.ebuild (renamed from dev-python/uranium/uranium-4.3.0.ebuild)18
3 files changed, 35 insertions, 19 deletions
diff --git a/dev-python/uranium/uranium-3.6.0-r1.ebuild b/dev-python/uranium/uranium-3.6.0-r1.ebuild
index fdbfe670aa9a..e2e7e3c9f1d2 100644
--- a/dev-python/uranium/uranium-3.6.0-r1.ebuild
+++ b/dev-python/uranium/uranium-3.6.0-r1.ebuild
@@ -21,18 +21,24 @@ RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- ~dev-libs/libarcus-${PV}:=[python,${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP},declarative,network,svg]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
- sci-libs/Shapely[${PYTHON_USEDEP}]
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},declarative,network,svg]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/scipy-1.1[${PYTHON_MULTI_USEDEP}]
+ sci-libs/Shapely[${PYTHON_MULTI_USEDEP}]
+ ')
dev-qt/qtquickcontrols:5
dev-qt/qtquickcontrols2:5"
DEPEND="${RDEPEND}
sys-devel/gettext
doc? ( app-doc/doxygen )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
DOCS=( README.md )
diff --git a/dev-python/uranium/uranium-4.2.0.ebuild b/dev-python/uranium/uranium-4.2.0.ebuild
index 8b3f307a109c..3154436aac0b 100644
--- a/dev-python/uranium/uranium-4.2.0.ebuild
+++ b/dev-python/uranium/uranium-4.2.0.ebuild
@@ -24,14 +24,20 @@ RESTRICT="!test? ( test )"
BDEPEND="${PYTHON_DEPS}
sys-devel/gettext
doc? ( app-doc/doxygen )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
RDEPEND="${PYTHON_DEPS}
- ~dev-libs/libarcus-${PV}:=[python,${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP},declarative,network,svg]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
- sci-libs/Shapely[${PYTHON_USEDEP}]
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},declarative,network,svg]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/scipy-1.1[${PYTHON_MULTI_USEDEP}]
+ sci-libs/Shapely[${PYTHON_MULTI_USEDEP}]
+ ')
dev-qt/qtquickcontrols:5
dev-qt/qtquickcontrols2:5"
diff --git a/dev-python/uranium/uranium-4.3.0.ebuild b/dev-python/uranium/uranium-4.3.0-r1.ebuild
index 4ca593a01581..b5516dcefb70 100644
--- a/dev-python/uranium/uranium-4.3.0.ebuild
+++ b/dev-python/uranium/uranium-4.3.0-r1.ebuild
@@ -25,16 +25,20 @@ BDEPEND="${PYTHON_DEPS}
sys-devel/gettext
doc? ( app-doc/doxygen )
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mypy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ dev-python/mypy[${PYTHON_MULTI_USEDEP}]
+ ')
)"
RDEPEND="${PYTHON_DEPS}
- ~dev-libs/libarcus-${PV}:=[python,${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP},declarative,network,svg]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
- sci-libs/Shapely[${PYTHON_USEDEP}]
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},declarative,network,svg]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/scipy-1.1[${PYTHON_MULTI_USEDEP}]
+ sci-libs/Shapely[${PYTHON_MULTI_USEDEP}]
+ ')
dev-qt/qtquickcontrols:5
dev-qt/qtquickcontrols2:5"