summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-28 05:52:00 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-28 06:06:41 +0100
commitb4afda7ce983db054e4e4320ce1a9666ea0ca1c8 (patch)
tree901cf532b9502b1923b52064a5c8d55f207e2cce /dev-python/vdirsyncer
parentdev-python/aws-sam-translator: Bump to 1.60.0 (diff)
downloadgentoo-b4afda7ce983db054e4e4320ce1a9666ea0ca1c8.tar.gz
gentoo-b4afda7ce983db054e4e4320ce1a9666ea0ca1c8.tar.bz2
gentoo-b4afda7ce983db054e4e4320ce1a9666ea0ca1c8.zip
dev-python/vdirsyncer: Bump to 0.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/vdirsyncer')
-rw-r--r--dev-python/vdirsyncer/Manifest1
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.19.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/vdirsyncer/Manifest b/dev-python/vdirsyncer/Manifest
index 1173cae68ca4..972e67cc782d 100644
--- a/dev-python/vdirsyncer/Manifest
+++ b/dev-python/vdirsyncer/Manifest
@@ -1,2 +1,3 @@
DIST vdirsyncer-0.18.0.tar.gz 115125 BLAKE2B d81bb9b51658d16a3b9ea044846561a1ce2dac3a839d7e0a165f0136069fcd0716525ab2b908be7cafed60846a1aed6fd72aa1d31fc2a38dbe6de8d0e6585226 SHA512 7fb3d0f7d982d8390d278de1a620231e6ead1ec64057c5dbac98dcff491fa3e6b9ed8ba953995458e393aab73b0b9ab8ba14010e06f90a04d8ee2c28c7c7fbfd
DIST vdirsyncer-0.19.0.tar.gz 122533 BLAKE2B 18e3359fb743a8ce71f80c46da21555c4984ca47791e1a4e899408050e4a4bbad184fa94026fede1168fa3a7695539d93f1985b85c640aa1c0ca4fdf52920766 SHA512 9b8e467bdc9daf6d50981bfec1f67a1c990b07bc62a6e2d3ede35712fde60206672af53d53aca6587daee132ab74bf74f04d8bb4dbaa804dfe97dca9370b323c
+DIST vdirsyncer-0.19.1.tar.gz 122699 BLAKE2B 31fd6351046f5e668312594fa698a647e67f4b66e989a60c2bc6312748f09ea7971d3b5c04ceacbedbb7618e75febfdf175a82f286ca9425f14828ff044997d5 SHA512 2b0917bf69cfa298600b6b35b50db12ca57e1a963baf2ea9839a3c2f9f686f2f83f47c01e44ad2e12287ecfd470fe1a9ee4a756c0f8985236c2fe8d0454b6a15
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.19.1.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.19.1.ebuild
new file mode 100644
index 000000000000..66223c31a60b
--- /dev/null
+++ b/dev-python/vdirsyncer/vdirsyncer-0.19.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi systemd
+
+DESCRIPTION="Synchronize calendars and contacts"
+HOMEPAGE="
+ https://github.com/pimutils/vdirsyncer/
+ https://pypi.org/project/vdirsyncer/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ <dev-python/click-log-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]
+ <dev-python/aiohttp-4[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-3.8.0[${PYTHON_USEDEP}]
+ <dev-python/aiostream-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/aiostream-0.4.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/aioresponses[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
+
+distutils_enable_tests pytest
+
+python_test() {
+ # skip tests needing servers running
+ local -x DAV_SERVER=skip
+ local -x REMOTESTORAGE_SERVER=skip
+ # pytest dies hard if the envvars do not have any value...
+ local -x CI=false
+ local -x DETERMINISTIC_TESTS=false
+
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/system/utils/test_main.py::test_request_ssl
+ )
+
+ epytest -o addopts=
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ systemd_douserunit contrib/vdirsyncer.{service,timer}
+}