summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/xhtml2pdf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/xhtml2pdf')
-rw-r--r--dev-python/xhtml2pdf/Manifest2
-rw-r--r--dev-python/xhtml2pdf/metadata.xml8
-rw-r--r--dev-python/xhtml2pdf/xhtml2pdf-0.0.5-r1.ebuild22
-rw-r--r--dev-python/xhtml2pdf/xhtml2pdf-0.0.6-r1.ebuild25
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/xhtml2pdf/Manifest b/dev-python/xhtml2pdf/Manifest
new file mode 100644
index 000000000000..f23a4bfe6797
--- /dev/null
+++ b/dev-python/xhtml2pdf/Manifest
@@ -0,0 +1,2 @@
+DIST xhtml2pdf-0.0.5.tar.gz 97399 SHA256 1f108c09d0939025069e71e099ec88fb477076bdc781e54215d28a8d42fe5868 SHA512 7c737e8c7ac1018f6f355488a2762a2b448383bb868a34a69e1012fc1c6dc4559d2eb4de1117ee3957712990f5837d7289dc9291a5b1ecb391be0aea53f9b64d WHIRLPOOL fbe3ab0cff346a695edaeeedd7f2256a8fc471ec5a23b9e25ae733b075f931b3de78addc236d091e818f02dff4c62243737fe8c00edfe08f7ac78d0b0da9c5aa
+DIST xhtml2pdf-0.0.6.tar.gz 100628 SHA256 29dbf7da8943ccef4afb958747cd0084762821546e3cc62d23115fd7470d95f0 SHA512 b79f3a1c465ddda20e6b8ac28324d78bbb100a764d1ecd9eaec80f22f67d9266112b93ddfde067a077754058969f09e9ebed227369c3e718693d35cf451b43e9 WHIRLPOOL 1ee4d093cc8c28431d208e7496af155f1b0cb92e45a754c87dc5367aa71332239df216ec3a2045b913d0b237e92ca379c0501c1f5654af5ed491e6ba96d010f9
diff --git a/dev-python/xhtml2pdf/metadata.xml b/dev-python/xhtml2pdf/metadata.xml
new file mode 100644
index 000000000000..c670146f07b0
--- /dev/null
+++ b/dev-python/xhtml2pdf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">xhtml2pdf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/xhtml2pdf/xhtml2pdf-0.0.5-r1.ebuild b/dev-python/xhtml2pdf/xhtml2pdf-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..46663da507da
--- /dev/null
+++ b/dev-python/xhtml2pdf/xhtml2pdf-0.0.5-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="PDF generator using HTML and CSS"
+HOMEPAGE="http://www.xhtml2pdf.com/ http://pypi.python.org/pypi/xhtml2pdf/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/html5lib[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/pyPdf[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/xhtml2pdf/xhtml2pdf-0.0.6-r1.ebuild b/dev-python/xhtml2pdf/xhtml2pdf-0.0.6-r1.ebuild
new file mode 100644
index 000000000000..8e8b9a77dadd
--- /dev/null
+++ b/dev-python/xhtml2pdf/xhtml2pdf-0.0.6-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="PDF generator using HTML and CSS"
+HOMEPAGE="http://www.xhtml2pdf.com/ http://pypi.python.org/pypi/xhtml2pdf/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/html5lib[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ >=dev-python/reportlab-2.2[${PYTHON_USEDEP}]
+ <dev-python/reportlab-3[${PYTHON_USEDEP}]"
+# on testing, this version fails under reportlab-3.*
+# which was still new and likely untested at time of release; Bug #530134
+RDEPEND="${DEPEND}"