summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-11 10:06:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-11 10:42:48 +0100
commit0aa2e1d794863d8c1b0a9283855d5d31b6697f4f (patch)
tree0fd59c8585cfa6c1a3924a6eb9838375c9b8c8f2 /dev-python/zope-exceptions
parentapp-accessibility/espeak-ng: Update LICENSE of live ebuild (diff)
downloadgentoo-0aa2e1d794863d8c1b0a9283855d5d31b6697f4f.tar.gz
gentoo-0aa2e1d794863d8c1b0a9283855d5d31b6697f4f.tar.bz2
gentoo-0aa2e1d794863d8c1b0a9283855d5d31b6697f4f.zip
dev-python/zope-exceptions: Bump to 4.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-exceptions')
-rw-r--r--dev-python/zope-exceptions/Manifest1
-rw-r--r--dev-python/zope-exceptions/zope-exceptions-4.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/zope-exceptions/Manifest b/dev-python/zope-exceptions/Manifest
index 39ac8c1944a5..67261529a5bd 100644
--- a/dev-python/zope-exceptions/Manifest
+++ b/dev-python/zope-exceptions/Manifest
@@ -1 +1,2 @@
DIST zope.exceptions-4.4.tar.gz 28243 BLAKE2B 9af0b99826d574218c149c5a378886d3b3ec16935c0b6b883c0e048b22ba5ffee8408597f612a668eb18fc855a236e3810d6320c984faca4b7c5dfb4c76b303b SHA512 6ef175271ad1d62b450533e4c7d8f7380ffac519be5c48be084be297ad21d21fd8be380d9b5e221a8dac6a4c792bab14abc707331415c2df88208cac9c34013e
+DIST zope.exceptions-4.5.tar.gz 29609 BLAKE2B 63c853105d3a588418f79e877aeedf0b001bbe52eb3e6c82687127a8cc0b8e424143e75c7a77b224ede31c5db0efb1bbc126e851dbc8bef5b856615b0717f6ea SHA512 f3f75b2f9ecfe74d3bb081904750769bf331fb594d266907782b7ce7f9d062c261b2f95a50ce21cf8917c56a25899274dae466a5b59afa5ec66480182df55bd2
diff --git a/dev-python/zope-exceptions/zope-exceptions-4.5.ebuild b/dev-python/zope-exceptions/zope-exceptions-4.5.ebuild
new file mode 100644
index 000000000000..8d9aedf70fd5
--- /dev/null
+++ b/dev-python/zope-exceptions/zope-exceptions-4.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="General purpose exceptions for Zope packages"
+HOMEPAGE="
+ https://pypi.org/project/zope.exceptions/
+ https://github.com/zopefoundation/zope.exceptions/"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-zope[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/zope-testrunner[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}