summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-20 09:07:58 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-20 09:39:57 +0100
commit10ca5231a3c5f141417a29da546467e36aac952f (patch)
tree7a7b5ca186b3430db6f8dda2b088fc45cbad470e /dev-python
parentsys-apps/util-linux: su requires PAM (diff)
downloadgentoo-10ca5231a3c5f141417a29da546467e36aac952f.tar.gz
gentoo-10ca5231a3c5f141417a29da546467e36aac952f.tar.bz2
gentoo-10ca5231a3c5f141417a29da546467e36aac952f.zip
dev-python/tomlkit: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.8.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 9229d0898d57..8eb9d9a6271e 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1 +1,2 @@
DIST tomlkit-0.7.2.tar.gz 159643 BLAKE2B 6946cdc4c991671eb9e38cf836196a0dfdb7aba2697db95f3fcee58652d3c8ba96295df447b8145f0143447339834015abbd60928d7588c68ae31c298fd6d2d4 SHA512 cfb17d133463c22ae8b76dd03587f23f6dafedfd2decdf15ae29fe5c05117ebd3e17057f49bdb17345386f5ce3073b1e5b1937c6ab6683aefb0fc0abd7571580
+DIST tomlkit-0.8.0.tar.gz 179067 BLAKE2B 871eb8371d94c76552d78a56adfbde5ebb9da4b93aa29229ae9aa279ae35fac488a1b4986169b818d2e5366883b8f246b44dc9075d0d9785b2d7d6f97e222ec1 SHA512 77b267201021e740d8134d0d5edfbef2cf077adac0b320d80887fdedda3f63f74df1957e8230976f16c80fcc58fd4cfabb195cccf0eda7d6cd29f5f65d362147
diff --git a/dev-python/tomlkit/tomlkit-0.8.0.ebuild b/dev-python/tomlkit/tomlkit-0.8.0.ebuild
new file mode 100644
index 000000000000..4f5efac12e87
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.8.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="https://github.com/sdispater/tomlkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest