summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-18 09:13:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-18 10:18:55 +0100
commit20836363be0d23aaa58ca1d24d7c85a5a3e02a08 (patch)
tree2095d6ff0dfd76d540cb4d9ddf6dd9700d641276 /dev-python
parentdev-python/itsdangerous: Bump to 2.1.0 (diff)
downloadgentoo-20836363be0d23aaa58ca1d24d7c85a5a3e02a08.tar.gz
gentoo-20836363be0d23aaa58ca1d24d7c85a5a3e02a08.tar.bz2
gentoo-20836363be0d23aaa58ca1d24d7c85a5a3e02a08.zip
dev-python/proto-plus: Bump to 1.20.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.20.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index e16e8c857cf5..8dd4862c6649 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1,2 +1,3 @@
DIST proto-plus-1.20.0.gh.tar.gz 65648 BLAKE2B 19cfcfde913896de83d17c36bacd7799a9f28ea20c4681266b2194c6521aef116f6a594df8be8912bdf55558d84a0ab09d283ec444ba114592ebb7017db257fe SHA512 1e399bc0ac686f33242c1d15c15255ec1815e94eaf87de03e5145cc6ed249048c3b8af081b70964cb7b6baf8286f6be2f461c3638331a2269a5b2d89976ffa6a
DIST proto-plus-1.20.1.gh.tar.gz 66180 BLAKE2B ee0299c8e9c9882ce417f6f885df18cd833dfbad80e0e92ca4e589eea794b0b00577d4c01fa69790f97f31d8bdfd20f07f4c7601bdf6ee28a7427f0e56714eb4 SHA512 12d9f76230d592c68083421bbb40c4b57741545c238227a743c275820a4d7ae53ea45d7ae5e73495b14736a95aa96250e243220f8b9bb5c988c12a2f84f654d6
+DIST proto-plus-1.20.3.gh.tar.gz 66941 BLAKE2B 359d95d37b8a4dad282cb9b33909982ffedca25cd3907583d689996d6e516143c0e4eb2b9bb06bc50e12fabe197f0622a3488cf21136decefe676980b20c7a9e SHA512 411089eb76508a5ca94d6b4228dd4bc1f8d01d4f5209bb2ab0e6e240d8061761c9c76cd03b3a4da7771b45a30df3b0ca4c17f7fca3ed6e710a9724ab7bc0f60d
diff --git a/dev-python/proto-plus/proto-plus-1.20.3.ebuild b/dev-python/proto-plus/proto-plus-1.20.3.ebuild
new file mode 100644
index 000000000000..dc2848b431d0
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.20.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="https://pypi.org/project/proto-plus/ https://github.com/googleapis/proto-plus-python"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme