summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-08 20:07:16 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-08 20:41:18 +0100
commit2654ea2bcb9ab0bdfd5457b00618b336639ce8fd (patch)
tree69d8c7281a37351a26df340f715f973d16253f61 /dev-python
parentdev-perl/SOAP-Lite: Bump to version 1.260.0 (diff)
downloadgentoo-2654ea2bcb9ab0bdfd5457b00618b336639ce8fd.tar.gz
gentoo-2654ea2bcb9ab0bdfd5457b00618b336639ce8fd.tar.bz2
gentoo-2654ea2bcb9ab0bdfd5457b00618b336639ce8fd.zip
dev-python/pypy: Remove half-broken USE=doc
The doc building code is currently broken as it is subject to Sphinx version mismatch, and given that we would need separate logic to select interpreter for the PyPy build, and for the sphinx call, it's better to remove the doc building altogether and possible reintroduce it as a separate package in the future. Closes: https://bugs.gentoo.org/643046
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy/pypy-5.10.0.ebuild10
-rw-r--r--dev-python/pypy/pypy-9999.ebuild10
2 files changed, 4 insertions, 16 deletions
diff --git a/dev-python/pypy/pypy-5.10.0.ebuild b/dev-python/pypy/pypy-5.10.0.ebuild
index 7cfed8fcca3b..286b7be69e1d 100644
--- a/dev-python/pypy/pypy-5.10.0.ebuild
+++ b/dev-python/pypy/pypy-5.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,7 +19,7 @@ LICENSE="MIT"
# pypy -c 'import sysconfig; print sysconfig.get_config_var("SOABI")'
SLOT="0/41"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 doc gdbm +jit libressl low-memory ncurses sandbox sqlite cpu_flags_x86_sse2 test tk"
+IUSE="bzip2 gdbm +jit libressl low-memory ncurses sandbox sqlite cpu_flags_x86_sse2 test tk"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
@@ -39,7 +39,6 @@ RDEPEND=">=sys-libs/zlib-1.1.3:0=
# don't enforce the dep on pypy with USE=low-memory since it's going
# to cause either collisions or circular dep on itself
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
!low-memory? (
|| (
dev-python/pypy
@@ -188,8 +187,6 @@ src_compile() {
cp -p "${T}"/usession*-0/testing_1/{pypy-c,libpypy-c.so} . || die
pax-mark m pypy-c libpypy-c.so
- use doc && emake -C pypy/doc html
-
einfo "Generating caches and CFFI modules ..."
# Generate Grammar and PatternGrammar pickles.
@@ -262,9 +259,6 @@ src_install() {
"${ED%/}${dest}"/lib-python/*2.7/test/test_{tcl,tk,ttk*}.py || die
fi
- # Install docs
- use doc && dodoc -r pypy/doc/_build/html
-
local -x PYTHON=${ED%/}${dest}/pypy-c
# we can't use eclass function since PyPy is dumb and always gives
# paths relative to the interpreter
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index fecf7b18d4e4..c0bc0a26454b 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,7 +20,7 @@ LICENSE="MIT"
# pypy -c 'import sysconfig; print sysconfig.get_config_var("SOABI")'
SLOT="0/41"
KEYWORDS=""
-IUSE="bzip2 doc gdbm +jit libressl low-memory ncurses sandbox sqlite cpu_flags_x86_sse2 test tk"
+IUSE="bzip2 gdbm +jit libressl low-memory ncurses sandbox sqlite cpu_flags_x86_sse2 test tk"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
@@ -40,7 +40,6 @@ RDEPEND=">=sys-libs/zlib-1.1.3:0=
# don't enforce the dep on pypy with USE=low-memory since it's going
# to cause either collisions or circular dep on itself
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
!low-memory? (
|| (
dev-python/pypy
@@ -194,8 +193,6 @@ src_compile() {
cp -p "${T}"/usession*-0/testing_1/{pypy-c,libpypy-c.so} . || die
pax-mark m pypy-c libpypy-c.so
- use doc && emake -C pypy/doc html
-
einfo "Generating caches and CFFI modules ..."
# Generate Grammar and PatternGrammar pickles.
@@ -268,9 +265,6 @@ src_install() {
"${ED%/}${dest}"/lib-python/*2.7/test/test_{tcl,tk,ttk*}.py || die
fi
- # Install docs
- use doc && dodoc -r pypy/doc/_build/html
-
local -x PYTHON=${ED%/}${dest}/pypy-c
# we can't use eclass function since PyPy is dumb and always gives
# paths relative to the interpreter