summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-11 07:17:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-11 07:51:51 +0200
commit4c671779c29f73a303e583e64fb86a0c3da691e5 (patch)
tree3bc959dc160e0c2dbd160166ff5f38edc87d104e /dev-python
parentdev-python/GitPython: Bump to 3.1.32 (diff)
downloadgentoo-4c671779c29f73a303e583e64fb86a0c3da691e5.tar.gz
gentoo-4c671779c29f73a303e583e64fb86a0c3da691e5.tar.bz2
gentoo-4c671779c29f73a303e583e64fb86a0c3da691e5.zip
dev-python/pyfakefs: Bump to 5.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.2.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 6074b50d63b0..0ffe45150a9e 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1 +1,2 @@
DIST pyfakefs-5.2.2.gh.tar.gz 219768 BLAKE2B be22ad269dcb8777c2fc6d8aed5079b84089980f5b62f1198ec2b4b3eea3688df3665bfc305a300e73917d65bc4209bc7bbf2a739d3852b1257036ca288a7846 SHA512 43ba719ad129f3e5188512a6f9b1eb8cfd7586f45a69c6623a9ae2429ca4dfa67d54cfc42032a599daaf736d46cb9e268c9f68150c16427667ed84e0917ed459
+DIST pyfakefs-5.2.3.gh.tar.gz 222076 BLAKE2B 01d24021be074058d865ac068f77de69721ad2f826f835f04776e8d17a8f4cfaeb85bce9a948d679951b8f028ef6d6b3377428d76c5d2d46afea3b78dffcee1e SHA512 5e4adeecb1e2341f3dee20d48b387de870cdab4ad27791951f98ba516f8f4cbe4f5e303c83725c2ce5a9cfaf34f771814b07c553983eb283aa7c3fd7f4e7690d
diff --git a/dev-python/pyfakefs/pyfakefs-5.2.3.ebuild b/dev-python/pyfakefs/pyfakefs-5.2.3.ebuild
new file mode 100644
index 000000000000..6e8a1c28b3aa
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}