summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-10 07:41:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-10 07:41:22 +0200
commit76fc351a937464ea5314bebb8312a2b6d0a07a20 (patch)
treec7de1ce41452b79c042c25156e21be52daa88f7b /dev-python
parentdev-python/blinker: Bump to 1.6.1 (diff)
downloadgentoo-76fc351a937464ea5314bebb8312a2b6d0a07a20.tar.gz
gentoo-76fc351a937464ea5314bebb8312a2b6d0a07a20.tar.bz2
gentoo-76fc351a937464ea5314bebb8312a2b6d0a07a20.zip
dev-python/dkimpy: Bump to 1.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dkimpy/Manifest1
-rw-r--r--dev-python/dkimpy/dkimpy-1.1.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/dkimpy/Manifest b/dev-python/dkimpy/Manifest
index adc8a6b6e0cb..b9e117c7e7bb 100644
--- a/dev-python/dkimpy/Manifest
+++ b/dev-python/dkimpy/Manifest
@@ -1 +1,2 @@
DIST dkimpy-1.1.1.tar.gz 66368 BLAKE2B 6b9107129a0857a384d90b9c7d3970177aa32edaaeb41d62dd4edc6fdf7e8c16e3160162aaed074f865d476dc3f7f20ad299f7034858c0fc59ef88c651552ae4 SHA512 46db739f48f5b3aa1605f12822bef61286767b8770685d5056fcebf8475f9cbc78265c792a0371226ffaa97a55703acc6f6ae63c44944cf29a392c8bf51d49b9
+DIST dkimpy-1.1.2.tar.gz 66466 BLAKE2B a202acba76b83bc6c9e82d02e45ae77a09aa016c77285efd8c1c291ca9633f1cb02335b86b6da232a291e6f9a9ae3b344f217a1539bc9bfd7b0cefcbff81ab4f SHA512 92d8427ffd58269d91d0ebc20b082cf110431aa73a1b49fb4565d69e84b6f99404eb7cd91a3c81683461e6ff6361084f41a147b35b36ae4824cffe756b78a9cb
diff --git a/dev-python/dkimpy/dkimpy-1.1.2.ebuild b/dev-python/dkimpy/dkimpy-1.1.2.ebuild
new file mode 100644
index 000000000000..7a71236ad9dd
--- /dev/null
+++ b/dev-python/dkimpy/dkimpy-1.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="DKIM and ARC email signing and verification library"
+HOMEPAGE="
+ https://launchpad.net/dkimpy/
+ https://pypi.org/project/dkimpy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/authres[${PYTHON_USEDEP}]
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "ARC support" dev-python/authres
+ optfeature "ed25519 capability" dev-python/pynacl
+ optfeature "asyncio support" dev-python/aiodns
+}