summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-30 23:31:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-30 23:31:01 +0200
commit7d3c7e46765e9d7f459e91b44413ec57bb18800d (patch)
tree5272c2584ffa396d569c446553fe44db1a813e1d /dev-python
parentdev-python/botocore: Bump to 1.21.52 (diff)
downloadgentoo-7d3c7e46765e9d7f459e91b44413ec57bb18800d.tar.gz
gentoo-7d3c7e46765e9d7f459e91b44413ec57bb18800d.tar.bz2
gentoo-7d3c7e46765e9d7f459e91b44413ec57bb18800d.zip
dev-python/boto3: Bump to 1.18.52
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.52.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index fa73fca16e5c..5f917136c2c8 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -11,3 +11,4 @@ DIST boto3-1.18.48.tar.gz 420028 BLAKE2B d6bbf60141f2806519bdd0f4f364698ac7ab6e8
DIST boto3-1.18.49.tar.gz 420662 BLAKE2B 92995cd06f19e26200ea51e6d171914ddbb20b860b286b34cf97ffc6c9ee4f29b59073d84cc7d99b2cd5349bbaff03ac004431ae2cf65af571044c6c52634f55 SHA512 4d94e11b974857709dc7907bd31a3eab087eafff3938286803d4d1bc850d90e4dd82be747a3a9c4725bb15e3670a12c8bd239a98df23198c498519d196279dc0
DIST boto3-1.18.50.tar.gz 420875 BLAKE2B 22bfcf6ffb6ae87bf45a907f50998f8a04555fccf5e327037c4127f31ea097bf497ad63d08875f10de91a19e9bc53a022caf37af6badf00c424f4e84882fa35c SHA512 25d524e7a96e6f9020dab689536b012a3c708fd03898240e8186df1c89dd049bb627488706abb687173e4d692c85d5258468c903319614f0854d3a4cfab5ac2e
DIST boto3-1.18.51.tar.gz 421143 BLAKE2B f3a943a2b8d91602017b70a0a4f9233a1c3d0bcd189594ba3b70db3d4a8b5f61758e0b7e5bc1658601b6fd58e47eb5ebf7d329a78ebd014b30d7047065b9c806 SHA512 88c6753bf12aff9c161276802be8936209197698065fb47a6ebf2d9de2b7cab7be9eef0779d612f9327cb444604baf1ca4527de60e7cd396c0a12e2495e6e838
+DIST boto3-1.18.52.tar.gz 421808 BLAKE2B f81c00ee211d3e9402d4b266030696fe40773364b145184cdcb57feee6f7011cbb16345177a4bd2fe74325b133c7e1690a95345a40cccaf14c48de1232dba4f0 SHA512 1ea23881c0a06fe1ad9b30b612b25d7a0b92fbd373483f0e0a604168cca77442fd963ac9363a8ce9cf4a412471e4a4951e7c4428b550c29571dcac3b1d041f8d
diff --git a/dev-python/boto3/boto3-1.18.52.ebuild b/dev-python/boto3/boto3-1.18.52.ebuild
new file mode 100644
index 000000000000..450c87d9f8b7
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.52.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}