summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-12 05:43:18 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-12 06:04:15 +0200
commit83bca55db03c309322bb1d315850e7eda59b0427 (patch)
treef1f26e6148ce5a36c3f7c97ec32f664e874cd8ba /dev-python
parentdev-lang/python: Bump to 3.12.0_beta4 (diff)
downloadgentoo-83bca55db03c309322bb1d315850e7eda59b0427.tar.gz
gentoo-83bca55db03c309322bb1d315850e7eda59b0427.tar.bz2
gentoo-83bca55db03c309322bb1d315850e7eda59b0427.zip
dev-python/scikit-build-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild
deleted file mode 100644
index 9cf9fc3a704b..000000000000
--- a/dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Build backend for CMake based projects"
-HOMEPAGE="
- https://github.com/scikit-build/scikit-build-core/
- https://pypi.org/project/scikit-build-core/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# we always want [pyproject] extra
-RDEPEND="
- >=dev-python/packaging-20.9[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/exceptiongroup[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.1[${PYTHON_USEDEP}]
- ' 3.9 3.10)
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest -m "not isolated and not network"
-}