summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-11 06:59:14 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-11 07:51:44 +0200
commitbfc66ad51668785a173fe77303acf24a7f5a6c63 (patch)
tree94d5df52203ad83120ea9c57dc673db080ad0cb7 /dev-python
parentdev-python/cryptography: Bump to 41.0.2 (diff)
downloadgentoo-bfc66ad51668785a173fe77303acf24a7f5a6c63.tar.gz
gentoo-bfc66ad51668785a173fe77303acf24a7f5a6c63.tar.bz2
gentoo-bfc66ad51668785a173fe77303acf24a7f5a6c63.zip
dev-python/black: Bump to 23.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/black/Manifest1
-rw-r--r--dev-python/black/black-23.7.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/black/Manifest b/dev-python/black/Manifest
index 1028a79ff922..ea99a0eaab16 100644
--- a/dev-python/black/Manifest
+++ b/dev-python/black/Manifest
@@ -1 +1,2 @@
DIST black-23.3.0.tar.gz 582156 BLAKE2B 01ed5443e1bb251d46618a5b61bbfcc2dc0b41c0bef7d4315fb704a2ac0fd51eb4fe268838b8be6195630f21e6f7b3a5bfca124a7bd60dbef95a02714924327b SHA512 1ea8749ee25aae34a40c5d1b779c6076971488dea1a85ebfcbe4c2a8bb5abb5e3918a735a4e3f9b4ae2690eda0f48fac014ade055721b54d879fdd2d3450b72b
+DIST black-23.7.0.tar.gz 586177 BLAKE2B 4bb50b6c7409a97aa277f1048c17101a1c91368b9269cf4c08d3052c036887d2ed6e5f1f2e044c14f41bf2d969d65183413c2a9810f12d96cbf09778c9b1310e SHA512 78d5e87bfef4dcaff007455e8c72dcd45f9374c09da6f4ba45ae7caa980005d1bc984c68fa44d4abf7969a376a4039546e7e8f537c3aa1331d213e13dcbe3941
diff --git a/dev-python/black/black-23.7.0.ebuild b/dev-python/black/black-23.7.0.ebuild
new file mode 100644
index 000000000000..dc0fca200e6d
--- /dev/null
+++ b/dev-python/black/black-23.7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="The uncompromising Python code formatter"
+HOMEPAGE="
+ https://black.readthedocs.io/en/stable/
+ https://github.com/psf/black/
+ https://pypi.org/project/black/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-22.0[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.10.0.0[${PYTHON_USEDEP}]
+ ' 3.9)
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/aiohttp-3.7.4[${PYTHON_USEDEP}]
+ dev-python/aiohttp-cors[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "blackd - HTTP API for black" \
+ "dev-python/aiohttp dev-python/aiohttp-cors"
+}