summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-18 12:56:37 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-18 12:59:38 +0200
commitc04631fe4657c54e0df405ac5f78ba2e5f6d9c48 (patch)
tree0584ced74cd64bb773c785f00c911fa5a4873abf /dev-python
parentapp-emacs/hl-todo: Remove old (diff)
downloadgentoo-c04631fe4657c54e0df405ac5f78ba2e5f6d9c48.tar.gz
gentoo-c04631fe4657c54e0df405ac5f78ba2e5f6d9c48.tar.bz2
gentoo-c04631fe4657c54e0df405ac5f78ba2e5f6d9c48.zip
dev-python/doit: add 0.34.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/doit/Manifest1
-rw-r--r--dev-python/doit/doit-0.34.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/doit/Manifest b/dev-python/doit/Manifest
index 0f9f50c21b7c..eea82ed78cb0 100644
--- a/dev-python/doit/Manifest
+++ b/dev-python/doit/Manifest
@@ -1 +1,2 @@
DIST doit-0.34.1.tar.gz 1447636 BLAKE2B 5b798ee2f291aa869bf03c492d0f6f9025e78ef5df95fadeafffdb953c159778dab30f75b0f9be24386748d362f6f380e34735891ed45f3511e819986b5788ca SHA512 ab5f9a56ee96d8b49f23f7d411eb4ee012639618b9604d65f61a2ce1ea1d1b42884277c08fe5ecd4b5097725d20b004457149e51f50a506d3daa9cade7ab858b
+DIST doit-0.34.2.tar.gz 1449767 BLAKE2B c7d81144da99147dbc6bf7d670b6f411879a8080e405866866bc97ae4701d9a47a3d4882db9672e2e36bc8af577ba9632da1fb4ed2c9f87717f719ac1cd53d34 SHA512 24afc8078fef42a446733554c6ab63298ee5bb734381fc2bfc9d623dc98394916a1f89a18bb28e7ef862da8c0449b5cf16d605295e8948a0ea6968a231a1c8e2
diff --git a/dev-python/doit/doit-0.34.2.ebuild b/dev-python/doit/doit-0.34.2.ebuild
new file mode 100644
index 000000000000..b499b853c2da
--- /dev/null
+++ b/dev-python/doit/doit-0.34.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="https://pydoit.org/ https://pypi.org/project/doit/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ || (
+ dev-python/toml[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND=">=dev-python/doit-py-0.4.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # test failing due to impact on PATH run in a sandbox
+ tests/test_cmd_strace.py::TestCmdStrace::test_target
+)
+
+src_prepare() {
+ # Replace custom theme with builtin for documentation
+ sed -e '/html_theme/s/press/sphinx_rtd_theme/' -i doc/conf.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp bash_completion_doit ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins zsh_completion_doit _${PN}
+}