summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-17 18:26:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-17 18:55:10 +0200
commitf06eb8d9883eb11f1dc60ba38aa080dacfb28188 (patch)
treee8bf570656e5f59964ba1c6861d88efbd486aee8 /dev-python
parentdev-python/tables: Bump to 3.10.1 (diff)
downloadgentoo-f06eb8d9883eb11f1dc60ba38aa080dacfb28188.tar.gz
gentoo-f06eb8d9883eb11f1dc60ba38aa080dacfb28188.tar.bz2
gentoo-f06eb8d9883eb11f1dc60ba38aa080dacfb28188.zip
dev-python/xxhash: Bump to 3.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xxhash/Manifest1
-rw-r--r--dev-python/xxhash/xxhash-3.5.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xxhash/Manifest b/dev-python/xxhash/Manifest
index e196e2c6a5a9..dbed3a0fbfef 100644
--- a/dev-python/xxhash/Manifest
+++ b/dev-python/xxhash/Manifest
@@ -1 +1,2 @@
DIST xxhash-3.4.1.tar.gz 84220 BLAKE2B 9bf0bc3ea15adbcf9c1b0dd526f406bd20ca11b6c25c2c771e34952d9bd3d2e85d121304bebfe47590573b4da73acf28d1726d0c628239ec9591738462cee3c0 SHA512 ab3c1fa5ce3ebefa13f87c60a700a897a080c576f1ce492bae9c47eb24a9d182cc8e71bfed81c8f0413ee261fd5522bdf44187043c9703958b72fa77e46a8953
+DIST xxhash-3.5.0.tar.gz 84241 BLAKE2B efe3fcfa02b15afd1539aa8667878868430337a9fe1decca03ae402893c743fd6f2e8dbbfae747e54a9bc6b65ba5cf5f4d2170181b88a820e9d4615b2b902ec7 SHA512 0242589264cba67eb535a0fffbfa8f171fe8c1991b8a90a1484311f283c9f49c81cae8a86552c43232aa9ac7ba66c989fda0a21bb403b3e8219b32db53941b2e
diff --git a/dev-python/xxhash/xxhash-3.5.0.ebuild b/dev-python/xxhash/xxhash-3.5.0.ebuild
new file mode 100644
index 000000000000..733105cff70f
--- /dev/null
+++ b/dev-python/xxhash/xxhash-3.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python binding for the xxHash library"
+HOMEPAGE="
+ https://github.com/ifduyue/python-xxhash/
+ https://pypi.org/project/xxhash/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/xxhash-0.8.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ export XXHASH_LINK_SO=1
+}
+
+python_test() {
+ cd tests || die
+ eunittest
+}