summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-17 22:22:28 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-21 12:03:21 +0100
commit12756c4a47fff3aea913d51fbb527be0110b2658 (patch)
treebf07adb6e0681d23256e7f583db486bbe444177c /dev-qt/assistant
parentdev-qt/qtxml: 5.15.3 version bump (diff)
downloadgentoo-12756c4a47fff3aea913d51fbb527be0110b2658.tar.gz
gentoo-12756c4a47fff3aea913d51fbb527be0110b2658.tar.bz2
gentoo-12756c4a47fff3aea913d51fbb527be0110b2658.zip
dev-qt/assistant: 5.15.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/assistant')
-rw-r--r--dev-qt/assistant/Manifest2
-rw-r--r--dev-qt/assistant/assistant-5.15.3.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-qt/assistant/Manifest b/dev-qt/assistant/Manifest
index 96e0c95cdef7..3628f53c69e4 100644
--- a/dev-qt/assistant/Manifest
+++ b/dev-qt/assistant/Manifest
@@ -1 +1,3 @@
DIST qttools-5.15.2-33693a92.tar.gz 12266718 BLAKE2B c519abdcca9df3b191297b859b2dce417ee9a79f9e3bcb3f2aa0017266b8edc855645108f5f7e6853d28f4c7507c92646ce8130731a345c6ffdfcd37fb1f4789 SHA512 9a62f1849c8eb65384d19de61cb6a08d1f467877181fd752e58b2b4e7d566c5d868c7ebab2d01591c6f540c01c705b7f8e0fe76c26cb0ee78f590ddae57048d2
+DIST qttools-5.15.3-gentoo-kde-1.tar.xz 1472 BLAKE2B eb4f5555127b91767a06c126795930a8331b8431e77dc6c689098dd0249dc324bec37f2f7e816505cc41fd9578d62110a41d2d064b3ca509a56600f967c31690 SHA512 5572b228cd80df8d49627bba4078943eed3e284de53336608ef7c2db36d6f9fd03be0f6060ccce79c59ab439650125fd59ad7d8ae16a2aeeebe4702f7b7f9354
+DIST qttools-everywhere-opensource-src-5.15.3.tar.xz 8896764 BLAKE2B 65a5d67a5f1c00c244ed91baf24ca10cd2e371963c4f55b3837701d71859b7adc03897db2021040eb08b85eb0f5d353bc8b9d7944aecbeec64397f7e0c20735f SHA512 3c4ffee1d67126e3dd10c1dabae3660b94b97541480814b77bc88c0eaf86d8d43324d582465521fbdbd49dbb4155561f93e91c998dc1ad6553da02a3fcb0da47
diff --git a/dev-qt/assistant/assistant-5.15.3.ebuild b/dev-qt/assistant/assistant-5.15.3.ebuild
new file mode 100644
index 000000000000..d2e3b01cf0d9
--- /dev/null
+++ b/dev-qt/assistant/assistant-5.15.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_KDEPATCHSET_REV=1
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*[png]
+ =dev-qt/qthelp-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtprintsupport-${QT5_PV}*
+ =dev-qt/qtsql-${QT5_PV}*[sqlite]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}
+ !dev-qt/${PN}:5
+ !<dev-qt/qtchooser-66-r2
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/assistant
+)
+
+src_prepare() {
+ sed -e "s/qtHaveModule(webkitwidgets)/false/g" \
+ -i src/assistant/assistant/assistant.pro || die
+
+ qt5-build_src_prepare
+}
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path assistant
+
+ doicon -s 32 src/assistant/assistant/images/assistant.png
+ newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
+ make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}