summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-10 04:38:31 +0100
committerSam James <sam@gentoo.org>2023-08-10 04:52:19 +0100
commit1deddd92c7791033da96aff0c8f9098c0ae95e15 (patch)
tree2afed34429500e6f62cf6b684e64b2a6d3a1b87c /dev-qt
parentmedia-gfx/jpegoptim: add 1.5.5 (diff)
downloadgentoo-1deddd92c7791033da96aff0c8f9098c0ae95e15.tar.gz
gentoo-1deddd92c7791033da96aff0c8f9098c0ae95e15.tar.bz2
gentoo-1deddd92c7791033da96aff0c8f9098c0ae95e15.zip
dev-qt/qtwebengine: fix build w/ binutils-2.41
Closes: https://bugs.gentoo.org/911688 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.15.10_p20230623-ffmpeg-binutils-2.41.patch75
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.15.10_p20230623.ebuild1
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild4
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.15.10_p20230623-ffmpeg-binutils-2.41.patch b/dev-qt/qtwebengine/files/qtwebengine-5.15.10_p20230623-ffmpeg-binutils-2.41.patch
new file mode 100644
index 000000000000..6b98df9bf5ae
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.15.10_p20230623-ffmpeg-binutils-2.41.patch
@@ -0,0 +1,75 @@
+https://bugs.gentoo.org/911582
+https://bugs.gentoo.org/911688
+https://trac.ffmpeg.org/ticket/10405
+https://git.videolan.org/?p=ffmpeg.git;a=commit;h=25cd95a9dc3510c3cc0d7aad6f9d83f6a1078c7e
+https://sourceware.org/PR30578
+https://gcc.gnu.org/PR108941
+
+From 25cd95a9dc3510c3cc0d7aad6f9d83f6a1078c7e Mon Sep 17 00:00:00 2001
+From: =?utf8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net>
+Date: Sun, 16 Jul 2023 18:18:02 +0300
+Subject: [PATCH] avcodec/x86/mathops: clip constants used with shift
+ instructions within inline assembly
+
+Fixes assembling with binutil as >= 2.41
+
+Signed-off-by: James Almer <jamrial@gmail.com>
+(cherry picked from commit effadce6c756247ea8bae32dc13bb3e6f464f0eb)
+--- a/src/3rdparty/chromium/third_party/ffmpeg/libavcodec/x86/mathops.h
++++ b/src/3rdparty/chromium/third_party/ffmpeg/libavcodec/x86/mathops.h
+@@ -35,12 +35,20 @@
+ static av_always_inline av_const int MULL(int a, int b, unsigned shift)
+ {
+ int rt, dummy;
++ if (__builtin_constant_p(shift))
+ __asm__ (
+ "imull %3 \n\t"
+ "shrdl %4, %%edx, %%eax \n\t"
+ :"=a"(rt), "=d"(dummy)
+- :"a"(a), "rm"(b), "ci"((uint8_t)shift)
++ :"a"(a), "rm"(b), "i"(shift & 0x1F)
+ );
++ else
++ __asm__ (
++ "imull %3 \n\t"
++ "shrdl %4, %%edx, %%eax \n\t"
++ :"=a"(rt), "=d"(dummy)
++ :"a"(a), "rm"(b), "c"((uint8_t)shift)
++ );
+ return rt;
+ }
+
+@@ -113,19 +121,31 @@ __asm__ volatile(\
+ // avoid +32 for shift optimization (gcc should do that ...)
+ #define NEG_SSR32 NEG_SSR32
+ static inline int32_t NEG_SSR32( int32_t a, int8_t s){
++ if (__builtin_constant_p(s))
+ __asm__ ("sarl %1, %0\n\t"
+ : "+r" (a)
+- : "ic" ((uint8_t)(-s))
++ : "i" (-s & 0x1F)
+ );
++ else
++ __asm__ ("sarl %1, %0\n\t"
++ : "+r" (a)
++ : "c" ((uint8_t)(-s))
++ );
+ return a;
+ }
+
+ #define NEG_USR32 NEG_USR32
+ static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
++ if (__builtin_constant_p(s))
+ __asm__ ("shrl %1, %0\n\t"
+ : "+r" (a)
+- : "ic" ((uint8_t)(-s))
++ : "i" (-s & 0x1F)
+ );
++ else
++ __asm__ ("shrl %1, %0\n\t"
++ : "+r" (a)
++ : "c" ((uint8_t)(-s))
++ );
+ return a;
+ }
+
diff --git a/dev-qt/qtwebengine/qtwebengine-5.15.10_p20230623.ebuild b/dev-qt/qtwebengine/qtwebengine-5.15.10_p20230623.ebuild
index 937b8d59b20d..12f7af2c3a26 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.15.10_p20230623.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.15.10_p20230623.ebuild
@@ -103,6 +103,7 @@ BDEPEND="${PYTHON_DEPS}
PATCHES=(
"${WORKDIR}/${PN}-5.15.8_p20230313-patchset"
"${FILESDIR}/${PN}-5.15.10_p20230623-clang16.patch"
+ "${FILESDIR}/${PN}-5.15.10_p20230623-ffmpeg-binutils-2.41.patch"
)
qtwebengine_check-reqs() {
diff --git a/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild b/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild
index bad90757778b..36bdb9c96769 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild
@@ -87,6 +87,10 @@ DEPEND="${RDEPEND}
media-libs/libglvnd
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.15.10_p20230623-ffmpeg-binutils-2.41.patch
+)
+
python_check_deps() {
python_has_version "dev-python/html5lib[${PYTHON_USEDEP}]"
}