summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:32:27 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:32:27 +0300
commit308c74e211ddb2be797c5cc8c33fd7c19af3616e (patch)
tree56598cfa8b37c1c415e061a805b1990e4f2bc196 /dev-ros/ament_lint_auto
parentdev-ros/ament_cmake_xmllint: use python_has_version inside python_check_deps (diff)
downloadgentoo-308c74e211ddb2be797c5cc8c33fd7c19af3616e.tar.gz
gentoo-308c74e211ddb2be797c5cc8c33fd7c19af3616e.tar.bz2
gentoo-308c74e211ddb2be797c5cc8c33fd7c19af3616e.zip
dev-ros/ament_lint_auto: use python_has_version inside python_check_deps
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-ros/ament_lint_auto')
-rw-r--r--dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild9
-rw-r--r--dev-ros/ament_lint_auto/ament_lint_auto-0.12.1.ebuild7
-rw-r--r--dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild9
3 files changed, 11 insertions, 14 deletions
diff --git a/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild b/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
index 7c0ae86f0a35..f4bba4298b4b 100644
--- a/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
+++ b/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,14 +30,13 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
-BDEPEND="
+BDEPEND="${PYTHON_DEPS}
$(python_gen_any_dep '
dev-python/ament_package[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
"
python_check_deps() {
- has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
- has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
+ "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}
diff --git a/dev-ros/ament_lint_auto/ament_lint_auto-0.12.1.ebuild b/dev-ros/ament_lint_auto/ament_lint_auto-0.12.1.ebuild
index 16d03e212bf3..f4bba4298b4b 100644
--- a/dev-ros/ament_lint_auto/ament_lint_auto-0.12.1.ebuild
+++ b/dev-ros/ament_lint_auto/ament_lint_auto-0.12.1.ebuild
@@ -30,14 +30,13 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
-BDEPEND="
+BDEPEND="${PYTHON_DEPS}
$(python_gen_any_dep '
dev-python/ament_package[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
"
python_check_deps() {
- has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
- has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
+ "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}
diff --git a/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild b/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild
index 7c0ae86f0a35..f4bba4298b4b 100644
--- a/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild
+++ b/dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,14 +30,13 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
-BDEPEND="
+BDEPEND="${PYTHON_DEPS}
$(python_gen_any_dep '
dev-python/ament_package[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
"
python_check_deps() {
- has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
- has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
+ "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}