summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:59:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 19:04:25 +0200
commit36e208a381451fb17427ed89dac6ae1d06a2cd3e (patch)
tree13e7d509960643fa8935f0be02fb04dbfa672102 /dev-ros/diagnostic_common_diagnostics/diagnostic_common_diagnostics-9999.ebuild
parentdev-ros/diagnostic_updater: Initial import. Ebuild by me. (diff)
downloadgentoo-36e208a381451fb17427ed89dac6ae1d06a2cd3e.tar.gz
gentoo-36e208a381451fb17427ed89dac6ae1d06a2cd3e.tar.bz2
gentoo-36e208a381451fb17427ed89dac6ae1d06a2cd3e.zip
dev-ros/diagnostic_common_diagnostics: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/diagnostic_common_diagnostics/diagnostic_common_diagnostics-9999.ebuild')
-rw-r--r--dev-ros/diagnostic_common_diagnostics/diagnostic_common_diagnostics-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_common_diagnostics/diagnostic_common_diagnostics-9999.ebuild b/dev-ros/diagnostic_common_diagnostics/diagnostic_common_diagnostics-9999.ebuild
new file mode 100644
index 000000000000..c06f3cd578f1
--- /dev/null
+++ b/dev-ros/diagnostic_common_diagnostics/diagnostic_common_diagnostics-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Generic nodes for monitoring a linux host"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ros/diagnostic_updater[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ app-admin/hddtemp"