summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:12:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 18:12:50 +0200
commit20da6d20a231a10f4183c5ca5e9e4d0479bdd8d4 (patch)
treee92b89d16d5fe0a2189435d3c2f6e4301805bef5 /dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild
parentdev-ros/angles: Initial import. Ebuild by me. (diff)
downloadgentoo-20da6d20a231a10f4183c5ca5e9e4d0479bdd8d4.tar.gz
gentoo-20da6d20a231a10f4183c5ca5e9e4d0479bdd8d4.tar.bz2
gentoo-20da6d20a231a10f4183c5ca5e9e4d0479bdd8d4.zip
dev-ros/turtle_actionlib: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild')
-rw-r--r--dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild b/dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild
new file mode 100644
index 000000000000..c2135ca855b5
--- /dev/null
+++ b/dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write an action server and client with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ dev-ros/actionlib_msgs
+ dev-ros/angles
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/turtlesim
+"
+DEPEND="${RDEPEND}"